Python and Snap

I tried to configure Python to use snappy interface but I have the following problems:

I tried using Python3.5 because it was recommended for snappy. The SNAP installed in my computer is version 8.

I’m not into python, but have you checked the spappyutil.log file to see if there are extra details there?
You can also try to search on the forum, maybe something can help:

[ Failed with return code 30]

Have you fully updated SNAP 8? What version of Windows?

There are many posts in the forum that discuss this issue. You appear to be using an Anaconda environment, but you don’t mention if you ran snappy_conf in an Anacoda terminal with the Python35 environment activated.

As mentioned in your screen capture, you should review the contents of snappyutil.log. If you are unable to fix the problem with the advice given in other posts, please attach snappytuil.log to a post.

PS – It is better to post terminal output by selecting the text and pasting that into a post because the text is searchable and can be found by the next person who encounters the same problem.

Thank you for this suggestion! Yes my SNAP is fully updated and Windows 10. \

I tried to do the snappy_conf and here is the snappyuntil.log

INFO: Installing from Java module 'C:\SNAP\modules\org-esa-snap-snap-python.jar'
INFO: Installing jpy...
ERROR: The module 'jpy' is required to run snappy, but no binary 'jpy' wheel matching the pattern
'jpy-{version}-cp39-{abi_tag}-win_amd64.whl' could be found.
You can try to build a 'jpy' wheel yourself, then copy it into
"C:\.snap\snap-python\snappy", and then run the configuration again.
Unzip the jpy sources in C:\.snap\snap-python\snappy/jpy-<version>.zip, then
  $ cd jpy-<version>
  $ python bdist_wheel
  $ cp dist/*.whl "C:\.snap\snap-python\snappy"
Or get the source code from and follow the build instructions:
  $ git clone
  $ cd jpy
ERROR: Configuration failed with exit code 10

The message shows that you used python-3.9, not 3.5. There are so many different Windows Python configurations that it is hard to get the desired version.

In a terminal, what does C:\Users\dtcal\anaconda3\envs\Python35\python.exe print?

It shows Python 3.5.5

That should work. Have you tried using the Anaconda terminal:

(base) C:\Program Files\snap\bin> conda enable Python35
(Python35) C:\Program Files\snap\bin> snappy_conf.bat <path to Python35>