Reprojection problem


I’m reprojecting a S2 level 1c image after resampling and subsetting. I have a problem when opening the reprojected product. It is empty and pixels have NaN values

Here are the screenshots of the process
Original image and projection

Resampled image and projection

Subset image and projection

Reprojection parameters


The same situation happens if I use the automtic WGS/UTM
Any idea?

Screen shots with parametes too small, cant see anything


I’ve been trying and if I select another UTM zone it works. I know I’m reprojecting in the same reference system as the one of the input but it is a necessary step in further processing.

1 Like

Better. Hmm, cant get why you trying to reprojecting in the same reference system? Try (for test) reproject and save in geotiff format. I noticed that sometimes save format make sense

So here is my situation

I am doing a MLC and a reprojection step is required for the process to work.

When reprojecting, if I use the “Use CRS of” and I choose the product [1] or [2] as reference, the scene width and height will not match the ones of product [3], which is a subset. Although the reprojection works when using this option, it creates a product with a bigger extent and in a further step, when exporting to GeoTIFF, it will have almost 1 GB size.

The solution would be then to reproject and create a product with the appropriate extent. This could be done using the “Custom CRS” or “Prefered CRS” options of the Reprojection tool. However, when trying I face the problem described before.

I know a solution could be just to subset again the product with the big extent, but I wondering why the other options are not working.

Hope its clear

Well, i almost get what you mean, but not at all. Any way if its a bug, you have to wait, until it’ll fixed

Hi @MCG,

I faced with same issue and first I reprojected via NAD27 projection and I changed NAD27 to Geographic Lat/Lon.

Hi @Fikretjfm,

Thanks for your input. I used also this approach, re-projecting into another CRS and then back to the CRS of my interest. It’ss a good solution to go around this problem but definitely should work without such an unnecessary step

I agree and I guess they are trying to fix this problem.

Have a good work.

I am bumping this topic because I have faced the same reprojection issue on any file I imported in snap.
I have found a workaround by definin NoData value to 0 and not NaN, but this is not consistant, I mean, it doesn’t work everytime.

I hope the developpers will look into the issue because classification doesn’t work on lat/long projection so I have to go through a reprojection each and everytime

I tried to reproduce the described behaviour.
What I’ve observed is that the NaN values are only introduced when trying to reproject to the same CRS, and doing this does actually make no sense.
I’ve tried with a resampled S2 MSI L1C product which is resampled to 60 meters. The CRS is already UTM 33N.
If reprojecting to Geographic Lat/Lon (WGS84) everything looks good. Reprojecting to ETRS89 / UTM zone 33N works, also reprojecting to UTM 32NN works. What does not work is to reproject to UTM 33N, and this is the original CRS. While this could be considered a bug it is not really serious because if you want to use this CRS you don’t need to do anything.

More serious is, that the classification seems to require the input data to be provided in geographic lat/lon. I’ve now created an issue for this.

1 Like