s2tbx.GDALInstaller error

SEVERE: org.esa.s2tbx.dataio.gdal.GDALInstaller: The GDAL library is available only on Windows operation system.

GPT produces this error message every time it starts (even if invoked with no options or “–diag”). Using SNAP 5.0.4 on Linux. (Also, the message is oddly inaccurate: the GDAL library is perfectly available, and in fact versions are already installed, for this operating system.)

Will this have implications for the behaviour of any gpt operators?

It is just a misleading log message. GDAL might be installed on your system but it must be configured for SNAP.
This should have no influence on your processing. Except you want to use GDAL readers/writers.

In SNAP 5.0.5, the error message is now:

INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
SEVERE: org.esa.s2tbx.dataio.gdal.activator.GDALPlugInActivator: The environment variable LD_LIBRARY_PATH is not set. It must contain the current folder ‘.’.
java.lang.IllegalArgumentException: The environment variable LD_LIBRARY_PATH is not set. It must contain the current folder ‘.’.
at org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller.processInstalledLinuxDistribution(GDALDistributionInstaller.java:109)
at org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller.install(GDALDistributionInstaller.java:82)
at org.esa.s2tbx.dataio.gdal.activator.GDALPlugInActivator.start(GDALPlugInActivator.java:22)
at org.esa.snap.runtime.Engine.informActivators(Engine.java:222)
at org.esa.snap.runtime.Engine.lambda$start$11(Engine.java:121)
at org.esa.snap.runtime.Engine.runClientCode(Engine.java:189)
at org.esa.snap.runtime.Engine.start(Engine.java:121)
at org.esa.snap.runtime.Engine.start(Engine.java:90)
at org.esa.snap.runtime.Launcher.run(Launcher.java:51)
at org.esa.snap.runtime.Launcher.main(Launcher.java:31)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:62)
at com.install4j.runtime.launcher.UnixLauncher.main(UnixLauncher.java:57)

Is it necessary to set this environment variable?

I got a similar error while running from IDEA :

SEVERE [org.esa.s2tbx.dataio.gdal.activator.GDALPlugInActivator]: /misc/archive06/visi/beaulima/projects/develop/snap/s2tbx/lib-gdal/target/classes/META-INF/MANIFEST.MF (Aucun fichier ou dossier de ce type)
java.io.FileNotFoundException: /misc/archive06/visi/beaulima/projects/develop/snap/s2tbx/lib-gdal/target/classes/META-INF/MANIFEST.MF (Aucun fichier ou dossier de ce type)

How do I resolve this


I have also got these errors. Wondering if anyone found out how to fix this?




I got the same INFO message and my output file is 42MB only. Did anyone solve this issue_


I also faced this error.
Anyone solved it?

Hi !

I have the same error, any update about it ? Or anyone having a solution ?

This thread was for SNAP 5.0.5, Please make sure your SNAP is the current version with all updates.

With the current version of SNAP you may get a WARNING rather than a SEVERE error. The WARNING can be ignored unless you need the GDAL I/O routines. If you are still having a problem using SNAP please start a new thread.

Meanwhile you can try deleting C:\Users[username].snap\auxdata\gdal and restart SNAP.
I didn’t really understood the error you have (the one from the post is old…).
Please note that WARNINGs are not errors.