sen2Cor 10 resolution error


i succesfully computed the L2A data via sen2cor command line interface.
As far as i understand the program is checking for 60m and 20m LUT before computing 10m resolution.
After creating 60+20m resolution i tried to start processing 10m resolution L2A data.
Everything is looking good, until exporting of bands is starting.

Heres the snap logfile:
INFO [org.esa.snap]: Executing tool 'org.esa.s2tbx.sen2cor' with command line: 'C:\Users\beck_ct\Programs\Anaconda\python.exe C:\Users\beck_ct\Programs\Anaconda\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor/ --resolution 10 D:\beck_ct\data\s2a\L1C\S2A_OPER_PRD_MSI_L1C_' INFO [org.esa.snap]: Sentinel-2 Level 2A Prototype Processor (Sen2Cor), 2.0.6, created: 2015.12.02 started ... INFO [org.esa.snap]: check if 20m table exists ... INFO [org.esa.snap]: check if 60m table exists... INFO [org.esa.snap]: Validating metadata file S2A_OPER_MTD_L1C_TL_MTI__20150817T213331_A000792_T29SMC.xml against scheme ... INFO [org.esa.snap]: Metadata file is valid. INFO [org.esa.snap]: L2A_Process: resolution 60 m already processed, elapsed time[s]: 1.311 INFO [org.esa.snap]: Progress[%]: 90.10 : L2A_Process: resolution 20 m already processed, elapsed time[s]: 0.015 INFO [org.esa.snap]: Progress[%]: 91.13 : L2A_Process: processing with resolution 10 m, elapsed time[s]: 0.016 INFO [org.esa.snap]: Progress[%]: 92.23 : L2A_Process: start of pre processing, elapsed time[s]: 0.000 INFO [org.esa.snap]: Progress[%]: 92.23 : Validating metadata file S2A_OPER_MTD_SAFL1C_PDMC_20150818T101504_R080_V20150817T114433_20150817T114433.xml against scheme ... INFO [org.esa.snap]: Metadata file is invalid, see logfile for details. INFO [org.esa.snap]: Validating metadata file S2A_OPER_MTD_L1C_TL_MTI__20150817T213331_A000792_T29SMC.xml against scheme ... INFO [org.esa.snap]: Metadata file is valid. INFO [org.esa.snap]: Validating metadata file S2A_OPER_MTD_L1C_DS_MTI__20150817T213331_S20150817T113558.xml against scheme ... INFO [org.esa.snap]: Metadata file is invalid, see logfile for details. INFO [org.esa.snap]: L2A_Tables: start import, elapsed time[s]: 1.497 INFO [org.esa.snap]: Progress[%]: 102.89 : L2A_Tables: band B02 imported, elapsed time[s]: 24.146 INFO [org.esa.snap]: Progress[%]: 1762.41 : L2A_Tables: band B03 imported, elapsed time[s]: 25.584 INFO [org.esa.snap]: Progress[%]: 3520.76 : L2A_Tables: band B04 imported, elapsed time[s]: 23.369 INFO [org.esa.snap]: Progress[%]: 5126.87 : L2A_Tables: band B08 imported, elapsed time[s]: 23.292 INFO [org.esa.snap]: Progress[%]: 6727.70 : L2A_Tables: band AOT imported, elapsed time[s]: 20.034 INFO [org.esa.snap]: Progress[%]: 8104.61 : L2A_Tables: band WVP imported, elapsed time[s]: 19.535 INFO [org.esa.snap]: Progress[%]: 9447.22 : L2A_Tables: band VIS imported, elapsed time[s]: 17.969 INFO [org.esa.snap]: Progress[%]: 10682.20 : L2A_Tables: band SCL imported, elapsed time[s]: 20.837 INFO [org.esa.snap]: Progress[%]: 12114.30 : L2A_Tables: stop import, elapsed time[s]: 0.007 INFO [org.esa.snap]: Progress[%]: 12114.78 : L2A_Process: start of Atmospheric Correction, elapsed time[s]: 0.002 INFO [org.esa.snap]: Progress[%]: 12114.92 : L2A_AtmCorr: starting data processing, elapsed time[s]: 0.025 INFO [org.esa.snap]: Progress[%]: 12116.63 : L2A_AtmCorr: end of calculation terrain maps, elapsed time[s]: 7.880 INFO [org.esa.snap]: Progress[%]: 12658.21 : L2A_AtmCorr: start of resampling visibility for 10 m resolution, elapsed time[s]: 0.005 INFO [org.esa.snap]: Progress[%]: 12658.56 : L2A_AtmCorr: end of resampling visibility for 10 m resolution, elapsed time[s]: 2.152 INFO [org.esa.snap]: Progress[%]: 12806.46 : L2A_AtmCorr: start of rho retrieval, elapsed time[s]: 2.723 INFO [org.esa.snap]: Progress[%]: 12993.61 : L2A_AtmCorr: end of rho retrieval preparation, elapsed time[s]: 3.354 INFO [org.esa.snap]: Progress[%]: 13224.12 : L2A_AtmCorr: end of rho retrieval step 1, elapsed time[s]: 204.115 INFO [org.esa.snap]: Progress[%]: 27252.65 : L2A_AtmCorr: end of rho retrieval step 2, elapsed time[s]: 78.514 INFO [org.esa.snap]: Progress[%]: 32648.80 : L2A_Process: start of post processing, elapsed time[s]: 0.088 INFO [org.esa.snap]: Progress[%]: 32654.85 : L2A_Tables: start export, elapsed time[s]: 0.003 INFO [org.esa.snap]: Progress[%]: 32655.05 : L2A_Tables: band B02 exported, elapsed time[s]: 26.806 INFO [org.esa.snap]: Progress[%]: 34497.39 : L2A_Tables: band B03 exported, elapsed time[s]: 26.988 INFO [org.esa.snap]: Progress[%]: 36352.23 : L2A_Tables: band B04 exported, elapsed time[s]: 26.209 INFO [org.esa.snap]: Progress[%]: 38153.54 : L2A_Tables: band B08 exported, elapsed time[s]: 25.412 INFO [org.esa.snap]: Progress[%]: 39900.07 : L2A_Tables: band AOT exported, elapsed time[s]: 5.008 INFO [org.esa.snap]: Progress[%]: 40244.26 : L2A_Tables: band WVP exported, elapsed time[s]: 9.501 INFO [org.esa.snap]: Progress[%]: 40897.25 : L2A_Tables: stop export, elapsed time[s]: 0.156 INFO [org.esa.snap]: Progress[%]: 40907.98 : Traceback (most recent call last): INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor/", line 295, in <module> INFO [org.esa.snap]: sys.exit(main() or 0) INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor/", line 283, in main INFO [org.esa.snap]: result = processor.selectAndProcess(tile) INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor/", line 89, in selectAndProcess INFO [org.esa.snap]: self._processed10 = self.process() INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor/", line 152, in process INFO [org.esa.snap]: if(self.postprocess() == False): INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor/", line 190, in postprocess INFO [org.esa.snap]: self.tables.postprocess() INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor\", line 1385, in postprocess INFO [org.esa.snap]: copy_file(self.config.configFn, target) INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\lib\distutils\", line 156, in copy_file INFO [org.esa.snap]: _copy_file_contents(src, dst) INFO [org.esa.snap]: File "C:\Users\beck_ct\Programs\Anaconda\lib\distutils\", line 41, in _copy_file_contents INFO [org.esa.snap]: "could not delete '%s': %s" % (dst, errstr)) SEVERE [org.esa.snap]: could not delete 'D:\beck_ct\data\s2a\L1C/S2A_USER_PRD_MSI_L2A_/GRANULE/S2A_USER_MSI_L2A_TL_MTI__20150817T213331_A000792_T29SMC_N01.03/AUX_DATA\S2A_USER_GIP_L2A_TL_MTI__20150817T213331_A000792_T29SMC.xml': Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird

I do not have opened any other program accessing the .xml. The only process working with the file is sen2cor itself.

I finally processed 10m resolution. I am still getting the error quoted above, but the whole image was processed. Could give me any feedback on how critical the issue is and how to solve it?
(SEVERE [org.esa.snap]: could not delete 'D:\beck_ct\data\s2a\L1C/S2A_USER_PRD_MSI_L2A_/GRANULE/S2A_USER_MSI_L2A_TL_MTI__20150817T213331_A000792_T29SMC_N01.03/AUX_DATA\S2A_USER_GIP_L2A_TL_MTI__20150817T213331_A000792_T29SMC.xml'

Thank you for your help.

Have a nice weekend,


i’ve got the same problem! nevertheless there’s a output, but i’m not shure if i can use it for further analyses.
help or any feedback would be awesome…


I encountered the same error. Have you found any solution or workaround? The big difference is that my output seems completely empty, all is grey.

Thank you in advance for your help


I have the same error starting the Sen2cor from the SNAP toolbox with 10m resolution. (SNAP 2.0, S2TBX 2.0.3, Sen2Cor 2.0.6) Only the first tile is processed, the others are missing.
Does anybody know how to fix it?

I encountered the same issue. I posted a message 20 days ago in this forum. Still waiting for suggestions. If you found any solutions, please share with us.

Greatly appreciated.


Just wanted to add another note that I’m experiencing the same problem, using Windows command line sen2cor.

Just to add that I am also experiencing the same issue using sen2cor 2.0.6 on Windows 7.


same here.
is there any development regarding this issue? Currently sen2cor does not provide any utilizable output.

Perhaps a redundant post, but it seems that I am encountering the same error as reported by others in this thread. I am also attempting to get output at 10m, and get the following message after SEN2COR has completed for over 50%. Suggestions are very welcome!

Hi all,

Exactly the same problem as the previous posts in this topic!
‘‘Quite happy’’ to not be alone with this issue …
Hope it will be fixed soon!



I’m currently restarting the L2A_Process for what feels like the 20th time, and at the moment the output directory contains (quick check…) 8 GRANULEs out of 13.

Apparently the process picks up where it left off, but we’ll have to wait and see if the final result is in any way useable. Besides, all this manual restarting is quite cumbersome; might help to cobble together a quick little batch file hack.

Thank you @ChristianSeverin!! I didn’t know it would pick up where it left off so thankfully it is indeed now working - not exactly smooth but it’s gone from unusable to inconvenient :wink:

Well…seems I spoke too soon - although repeat runs of Sen2Cor do continue processing where they left off it seems that SNAP can’t see the output :frowning: So back to Sen2Cor being unusable unfortunately.

Possible workaround: Workaround for sen2cor bug at resolution 10 m .

Hi! I got the same problem with 10 m resolution. Trying with 60 m everything is ok but with 10 m it did not work, error message is always the sam:

I was taking a look to the possible workaround Christian posted but my does not have these lines command (version sen2cor-2.0.6). Does anyone know how to solve it? I would like to work with 10 m resolution in order to get pixels close to coast.

Thanks in advance.

In addition, Only the first granule is processed (all 20 and 60 m bands, but half of 10 m bands), the others are missing and data seems to be invalid.
Does anybody know how to fix it?

Yeah,I’ve came across the same situation.Have you solved this problem?

If u use all resoulutions it works fine for me.