Sen2Cor 2.8 Launch

Hi, Everyone!
I found strange problem with Sen2cor v.2.8 execution. It doesn’t start after first attempt of processing of L1C data regardless 14.2 and 14.5 version. No error message. Just short progressbar blinking.
However, if I process data by sen2cor 2.5.5 first, then sen2cor 2.8 starts and processes same data.
So, in most cases I need processing data twice.
Can anyone halp me understanding what happens?

I had the same experience yesterday. The package is installed and integrated, the system variables are set correctly. It works when called in the command line, but inside SNAP the module somehow fails to start properly.

It seems, that I have similar problem as @ABraun mentioned, however, from tools ---- > manage external tools it runs properly ,

Yes, I always start sen2cor from tools–>manage external tools. And sometimes two or three scenes migh’t be processed simultaneously. But the first one (after starting SNAP), requires sen2cor v.2.5.5 processing first

Dear @kraftek and @obarrilero would you please to take a look at the problem we face up right now concerning cen2cor 2.08 operator,

could you try up command line, as @ABraun said,

we are investigating this issue.

the bug should be fixed in the new version of the plugin sen2cor280 v 6.0.1 already available in the SNAP update center.

Yes, it’s available within update, once I updated the SNAP, the last problem concerning of sen2cor 2.8 already mentioned in this post is solved, Source of the post

When launch the SNAP again similar above problem comes out, and sen2cor 2.8 gives error,
And still doesn’t run for any of the resolutions ALL, 10, 20, 60, once it run finished the process quickly in zero time minutes, and the output result only three bands, couldn’t be opened.

Nevertheless, 2.5.5 works normally with the same product. I run it directly from the SNAP (Tools ---------> manage external tools).

I am also having the same problem trying to run the updated Sen2Cor280 from SNAP.

The other option (Sen2Cor255) has worked fine from SNAP on the same files.
All the way back to 2017 10 31. For L1C products before that date Sen2Cor255
does not work correctly either. I gather this is probably an issue with a change
in the definition of the content of the product, version number change. Is that
when the PSD 14.5 to 14.2 happened?

The error message is appended.

Any advice on what I should try to address this issue. Am away for
some days so probably no immediate reply from me.

Thanks, Andrew.

Progress[%]: 24.91 : PID-2582, L2A_Tables: band VIS exported, elapsed time[s]: 0.736, total: 0:10:53.609458
Process L2A_ProcessTile-1:
Traceback (most recent call last):
File “/Users/ataylor/.snap/auxdata/Sen2Cor-02.05.05-Darwin64/lib/python2.7/multiprocessing/”, line 258, in _bootstrap
File “/Users/ataylor/.snap/auxdata/Sen2Cor-02.05.05-Darwin64/lib/python2.7/site-packages/sen2cor/”, line 136, in run
if not self.process_10():
File “/Users/ataylor/.snap/auxdata/Sen2Cor-02.05.05-Darwin64/lib/python2.7/site-packages/sen2cor/”, line 179, in process_10
if not self.process_20():
File “/Users/ataylor/.snap/auxdata/Sen2Cor-02.05.05-Darwin64/lib/python2.7/site-packages/sen2cor/”, line 158, in process_20
return self.process()
File “/Users/ataylor/.snap/auxdata/Sen2Cor-02.05.05-Darwin64/lib/python2.7/site-packages/sen2cor/”, line 229, in process
if self.postprocess() == False:
File “/Users/ataylor/.snap/auxdata/Sen2Cor-02.05.05-Darwin64/lib/python2.7/site-packages/sen2cor/”, line 311, in postprocess
if not self.tables.exportBandList():
File “/Users/ataylor/.snap/auxdata/Sen2Cor-02.05.05-Darwin64/lib/python2.7/site-packages/sen2cor/”, line 2307, in exportBandList
fn = os.path.basename(self._L2A_Tile_PVI_File)
AttributeError: ‘L2A_Tables’ object has no attribute '_L2A_Tile_PVI_File’

The problem with the sen2cor2.8 plugin should be fixed with a new module update (6.0.2). Please, before updating the plugin, delete Sen2Cor280 in Menu->Tools->Manage External Tools ( it will be created automatically again when restarting).

1 Like

Thanks a lot, that’s mean it’ll be available within the SANP 7.0 beta final release!

The bug was only for SNAP 6, in the 7.0 beta version it should work properly already.

1 Like