Sen2cor could not open XML file

i worked in sen2cor tool till November 3rd week it was working fine. now i try to open the xml file in sen2cor tool, i cant open the xml file it shows could not be read.



I am not able to reproduce the error, but it seems that there is a problem with the format. Are you able to open the product in SNAP? Could you check that, in the same folder where it is the xml file, there are the ‘GRANULE’ and ‘DATASTRIP’ folders of the product?

1 Like

Thanks for your suggestion @obarrilero. I tried to open in SNAP from GRANULE and DATASTRIP folders i got the following error messages.

1 Like

I am sorry @tmaya, I am not able to see the error in the image with this resolution.

But I think I have not explained to me well. I meant that you should verify that the data format is right (see To open the product you have to select the xml but then SNAP is going to look for some files in a specific structure and if it cannot find them it is not going to identify the product as a Sentinel product.

no @obarrilero I sure that there is no problem with the data because i used that same data before. That time it was worked well and i got the output in 10m 20m and 60m.

And my question is recently sen2cor tool was updated on 29 nov 2016, error accure may be because of that updates?

till november 3rd week i used the sen2cor tool and i got the outputs with the same data sets.

Your problem seems to be related to the Sentinel reader in SNAP (Sentinel-2 Toolbox), no to sen2cor.
When you select the source product in the sen2cor window in SNAP, the Sentinel reader is used to read the product and I think that it is in this step when you have the error. To confirm this, try to open the product in SNAP directly, without using the sen2cor and please tell me if it is properly opened.
Which versions of SNAP and S2TBX are you using (Help -> About SNAP…)

i got following error when i tried to open the data in snap directly.

my SNAP version is 4 and SNAP Desktop Implementation Version is 4.1.0
S2TBX version is 4.0.2

Could you try to install the latest version and check if you get the same error?

I installed SNAP(Version5) but now also i got the same error while opening the data directly in SNAP. and now i m facing one more issue also that sen2cor tool also not opening now.

Do you have problems with an specific product or with every Sentinel2 products?

All the Sentinel-2 data.

Hi tmaya,

Could you tell me from where have you downloaded the products or share with me one of them? I am trying to reproduce the error to be able to help you.
It seems that the reader does not recognize the structure of the product and there are some reasons for that:

I download data from USGS ( site.
the xml file is now opening in snap directly.
and sen2cor tool itself not opening after update snap 5. i mean i clicked sen2cor tool botton but i didnt get any window that to import for the xml file. till yesterday that was open and it shown some error message (xml could not be read).

Hello tmaya

I had the same problem when I started to process the new tiles. I solved it installing the new SNAP version (5.0) and also installing again Anaconda and sen2cor. The problem is that 5.0 version shows less possibilities to open the image (just the time zone but not reprojection to other pixel resolution). Try also to download and decompress again the image (I had also solved some problems doing it).

in SNAP 5.0 version sen2cor tool is coming inbuilt. again we have to install the sen2cor?

i reinstall SNAP 5.0 and sen2cor tool also there, my problem is that sen2cor tool is not opening when i clicked sen2cor.

After installing sen2cor i didnt get the environmental variable (SEN2COR_HOME) in my default place…

My basic problem is that everytime I open SNAP I have to uninstall sen2cor (go to Plugins/Installed_uninstall/Available_install) an reinstall it again to see in Manage external tools the option to run it. When you edit sen2cor from Manage external tools and edit it you will see that sen2cor_home, sen2cor_bin and phyton_bin are not in shared mode. I click them and after that it works. Before run sen2cor I open the image. I am not sure how orthodox is my method, surely not at all but it runs to me and my colleague.