Sen2cor (detailled instructions)

Hi guys,

I am having the same problems as nicola.colaninno. I installed SNAP 6.0 on a Windows 10 operating system. I did not download the standalone version of Sen2Cor or the Anacona one, I just followed all the steps described above. I do have something from SNAP in my user variables of the environment variables (C:\Program Files\snap\bin), but not from Sen2Cor. However, every time I try to run Sen2Cor on images that I downloaded from, I get an empty AUX_DATA and an empty DATASTRIP file within seconds. I am not very good with computers so this plugin use via SNAP seemed perfect for me, but I just cannot manage it to work properly. Does anyone have suggestions on how to deal with it, or on another way of using Sen2Cor?

In addition to above: it seems to work when I directly import the MSIL1C file in the Sen2Cor plugin, so I do not import the MSIL1C file in SNAP but directly load it in the I/O parameters and then run it

1 Like

I guess it has to do with the directorry in which the satellite data is stored… Now I just unzipped the file I downloaded from scihub in my C:\users\documents folder (same as sen2cor) and then it works. Hope this is helpful to others who are struggling with the same problem.

1 Like

two very important hints, thank you for sharing!

1 Like

Found another possible source of the “cannot create L2A product” and the sen2cor “finished processing in 0 seconds” that I had. If you are experiencing this - check the file-folder structure of your unzipped S2*_MSIL1C*.SAFE folder and the archive zip you downloaded. In my case after unzipping and/or copying the .SAFE folder between drives the AUX_DATA folder in the unzipped .SAFE folder got deleted or was not copied or was not unzipped, may be due to it being an empty folder.

My solution was as simple as creating the AUX_DATA folder in the .SAFE folder, and now sen2cor runs from command line without problem even on .SAFE files deep in the folders on a separate drive (not system drive where sen2cor is installed). Hope this helps someone.


That’s odd, surely unzipping should create the empty folders too.

I just tried it again and the program “RAR opener” from windows app store omits the AUX_DATA folder in the unzipped .SAFE folder. It’s not there. However the winrar program does unzip ok it seems both single file and batch. Standard windows zip-folder process does not allow batch unzipping which is why I tried other programs.

From my experience 7-Zip is one of the best unzipping tools. It also works well on the command line.

I also had the same problem as Nicola.Colaninno, the problem was that SNAP is able to work with images even if they are compressed in the format. zip while Sen2cor is not capable, it needs the file to be unzipped.
The ABraun procdeure is correct.

1 Like

Hi, I am running into problems trying to integrate Sen2Cor (v. 2.5.5) to SNAP (v6.0) on Linux 64bit. I have tried both ways, to install Sen2Cor stand alone and link it to snap and to use the bundle installation. I am however still not able to run it . In command line the process runs without errors but in SNAP the Environment variables are reset to some defaults each time I open SNAP and if I reset them manually and attempt to run Sen2Cor I get following error:

I would be grateful for any suggestions you might have.

Dear Tereza,
The SNAP development team is working on a new adapter(plugin). The current SNAP adapter/plugin v6.0.0 is not working with Sen2Cor 2.5.5 due to some parameters changes. In a few days, a new adapter (SNAP plugin) will be available through SNAP update and the update will be announced.

1 Like

Ah OK, thank you for the update.

@ABraun can I make an atmospheric correction for some AOI (area of interest) with sen2cor 2.4.0?

I don’t think subsetting before running sen2cor works. You usually process the whole tile.
About the degree of atmospheric correction, please see this post: Sen2cor 2.4.0 on SNAP 6.0 (comparison at the end on what can be achieved with sen2cor regarding clouds.)

Hi everyone,
I got the problem with you.
I set up sen2cor version 2.5.5 with Snap 6.0.
It worked well, but after processing, I can’t open file MTD.MSIL2A.xml. This is the error message

I checked the folder AUX_DATA and no data in it.
I don’t know why it is. Anyone can explain and give solution. ?

Thank you very much.

Usually it is sufficient to ask a question once.

Have you already tried an update?

After updating, my sen2cor worked well. However, the output of L2A lack some band, example band 8 in my case. Anyone can explain for me?
Thank you very much

I install sen2cor as the above comments, but it works for resolution 20 , 60, and does not work for resolution 10.
I reinstall too, but it does not work again
I do not know how I can solve it. please help me
first of all, the child missing error, I confront
but now i confront to ::::

Process L2A_ProcessTile-1:
Traceback (most recent call last):
File “C:\Users\elahe akbari.snap\auxdata\Sen2Cor-02.05.05-win64\lib\multiprocessing\”, line 258, in _bootstrap
File “C:\Users\elahe akbari.snap\auxdata\Sen2Cor-02.05.05-win64\Lib\site-packages\sen2cor\”, line 136, in run
if not self.process_10():
File “C:\Users\elahe akbari.snap\auxdata\Sen2Cor-02.05.05-win64\Lib\site-packages\sen2cor\”, line 183, in process_10
return self.process()
File “C:\Users\elahe akbari.snap\auxdata\Sen2Cor-02.05.05-win64\Lib\site-packages\sen2cor\”, line 223, in process
if ac.process() == False:
File “”, line 3163, in L2A_AtmCorr.L2A_AtmCorr.process (L2A_AtmCorr.c:73951)
File “”, line 7745, in L2A_AtmCorr.L2A_AtmCorr.rho_retrieval_step1 (L2A_AtmCorr.c:205814)
File “”, line 8950, in L2A_AtmCorr.L2A_AtmCorr.refl2rad (L2A_AtmCorr.c:244712)

“Memory Error” indicates that your computer couldn’t provide the required processing capacities.