Sen2Cor for Sentinel2 1C to Sentinel2 2A

Hi, I am rather new to analysing satellite images so of course I ran into a problem I think there is no solution to… I am trying to change an image from Sentinel 1C format to a Sentinel 2A format. From google earth engine I downloaded a tiff file of an image. I also successfully installed the Sen2Cor script and I am able to run it. However, when running the following command in my terminal: sen2cor /Users/admin/Desktop/August2018.tiff I get the following error: elif path == '' or path.endswith('/'): AttributeError: 'NoneType' object has no attribute 'endswith'

Am I supposed to pass the image in a different format than in .tiff?

Any help would be much appreciated!
Many thanks in advance,
Marko

The tiff files will not work. You need official ESA S2 L1C products.
You can get them from Open Access Hub (copernicus.eu),
There you can get L2A products too.

1 Like

You can also get them from here:

1 Like

Ohh thanks, much appreciated! This shall save me a lot of grey hair

Hey @marpet , the data I want to download is ‘offline’, how long does it usually take for such data to be ready for download?
Many thanks for your help,
Marko

Hey Pompey21, I don’t know. I haven’t ordered a product yet.
Alternatively, you could go to CREODIAS
There you can get also older data immediately.

1 Like

Hello
Offline products are in LTA (Long Term Archive). If they are greyed out, clicking the download adds them to your Cart. In my experience, the wait is a lot less than an hour, typically. If the product in your cart is still greyed out after a while, try to refresh the page, and it may appear.

Cheers

Jan

2 Likes

@marpet & @Jan thank you very much, that was very helpful! I finally got my data in the .SAFE format. When I try to run sen2cor /Users/admin/Desktop/S2A_MSIL1C_20160814T100032_N0204_R122_T33TVL_20160814T100604.SAFE I get the error of Product metadata file cannot be read.
Am I again passing the wrong file into the converter?
Apologies to constantly give you follow up questions but your advice has been a tremendous help!

This seems to be an issue with the current 2.10 version.

1 Like

ohh sweet, I shall then try and download 2.08 version!
Many thanks to both (@marpet & @Jan)!