Sen2cor llinux error

I have SNAP and sen2cor installed on a linux machine. When I run the command

L2A_Process --resolution 60 S2B_MSIL1C_20170817T222019_N0205_R029_T60KYG_20170817T222017.SAFE

I get the following error:

Sentinel-2 Level 2A Processor (Sen2Cor). Version: 2.5.5, created: 2018.03.19, supporting Level-1C product version <= 14.5 started ...
Product version: 14.2. Operation mode: TOOLBOX. Processing baseline: 02.05.
[CRITICAL]  L2A_Config: 3181   Error in creating L2A User Product
[CRITICAL]  L2A_Config: 3181   Error in creating L2A User Product

I can’t find anything in the docs about L2A_Config: 3181 and the error seem a little spurious. I’ve looked at the cfg file and nothing seems untoward.

I have the same error, did you figure out what caused it?


Please, have a look to:

I was able to get mine to run and I think it might have to do with the fact that I was trying to process an image in a google drive folder. I’m not sure why, but when I moved the .SAFE folder outside of google drive and ran the same command it worked fine.

obarrilero - what are you typing into your command line and what error are you getting?