Sen2cor TCI image export fail

Hi was this ever solved? I have the same problem!

Hi, I have the same problem as well with sen2cor 2.5.5 on Windows 10. Does anyone have a solution?

Same problem either within SNAP or in command-line in Windows 10. In Windows 8.1 it works fine (within SNAP; I haven’t tried it in command line yet)

Same problem, it never stop and TCI is not exported… Stayed around 98% of processing … Any ideas to solve this issue ?

Which version of sen2cor do you use, and which version of SNAP you have? ,


I download the version standalone of sen2core 2.5.5… I tried to find the version 2.4.0 but impossible to find it somewhere.
I also tried the version 2.8 but it’s actually not running at all.

For SNAP i have the version 5.0, but i thought there was no link between the standalone of sen2cor and the software.

The problem is the same for any images … i tried different Level 1C SAFE folder but nothing change still this [CRITICAL ERROR] on TCI export.

I checked the where the process for TCI is happening … and I don’t understand why there is an error because it’s basically doing the same for PVI …

Fist thing, you should remove this one version 5, please take a look at the following posts when you uninstall the version 5,

Source of the post

Source of the post

and install the latest version 6. from here, after successful installation, from help tab, check for update

Source :

This version should be compatible with latest version of SNAP, However, it has problem under investigation,

Take a look at this post,

Source of the post

How to install and implement sen2cor version 2.08 please take a look the following thread,

Source of the thread

As I mentioned sen2cor has problem of implementing directly from SNAP, Nevertheless, you could implement it from the command shell,

Take a look at the following post,

Source of the post

I’m actually implementing sen2cor from the command shell. I believe that it’s just the export that is not working. I print every step of the TCI operation in and it doesn’t show any particular mistakes…


It look like it comes frome the glymurWrapper because i got an array ‘a’ of 3 bands… but i don’t really understand how it work after …

I will check the other links you sended.

It’s not possible to implement it as py, script.

Please read all my previous post carefully once more, did you updated your SNAP?,

I updated SNAP to 6.0…
I’m only using the command line of Sen2cor with : C:\Users\mhouel\Sen2Cor-02.08.00-win64\L2A_Process.bat C:\directory of L1C.SAFE or C:\Users\mhouel\Sen2Cor-02.05.05-win64\L2A_Process.bat C:\directory of L1C.SAFE…

I tried both version of sen2cor, and i had two different errors, for sen2cor 2.8.

Here the problem is probably with the package OpenJPEG …

For sen2cor 2.5.5

Here it doesn’t succeed to export TCI image and do a loop for all processing …

This way is not correct, to call sen2cor from the command line, first thing you need to add the sen2cor to your path, please have a look at the following post, How to add up sen2cor to the path,

Source of the post

After adding up sen2cor to your path, typing the following statement in your console

L2A_Process.bat --help

Should gives you the following result,

Also here is an example of call and implement sen2cor from the console,


I added sen2cor to my path

When i’m doing L2A_process.bat --help i got the same result than you

But when im launching an example like yours i got the same error than last time,

I tried with -resolution=10, without resolution, etc…

if you called the resolution with one dash - this gives an error, you should call it as two dashes, –

I’m doing it with two dash --, the error is based on something else …

which python do yo have in your machine?

Python 3.7 i think

I’m not sure, but might be this is the python problem, since all the messages error in your shell, concerning the python,

But let’s do the last try, if you didn’t do it,

Navigate to the directory, where the granular is existed and then, implement L2A_ , as I explained before,

Please let me know in case you did it, or you’ll do it,

I think i found why I had issues …

I remembered that the software SNAP don’t like where the path to a file is too long (with too many subfolders). So i just changed the folder where we can find my image L1C to a folder closer to se base of my hard drive. And it finally work, no more issues with Sen2Cor 2.5.5, the command line is working and i can implement it my python script to do the processing on multiples images. I didn’t try with sen2cor 2.8 but as it work with the other version i don’t need it.

Well thank you for your help anyway, and I hope that this information about folders will be usefull.

1 Like

Happy to help, and I’m very delighted that I solved your matter,

This indeed solved both the issue. Otherwise, the L1C to L2A processing (in cmd) always terminated with ‘application terminated with at least one error’ or went on an infinite loop with the error ‘TCI image export failed’.