Sen2cor tool - black new window

I am trying to process a L1C image into L2A using sen2cor.

When I run the tool a new window opens as I checked “Display execution output”. But the window is total black and nothing seems to happen. I’m using sen2cor 2.2.1 version.

I already checked the systems variables and everything seems OK. I also didn’t get any error during the installation.

Please help


1 Like

Same here.

Installed for first time on Win 10, 64 bit.

Followed all steps in PDF; loaded Anaconda - checked okay; loaded sen2cor - checked okay; installed plugin to SNAP 3.03 - no reported problems.

When running sen2cor in 10, 20, or 60 resolution nothing happens. Black window opens but no messages. No CPU, memory, disk etc activity beyond background windows processing.

The program seems to hang with no errors - doesn’t seem to even start to process.


Found a solution here:

I have created a variable named PYTHON_BIN as a system variable in the Control Panel of Windows with the location of python.exe at Anaconda folder.

Now the tool begins to run but I get the error

1 Like

I assume you are working with Windows and long filenames. If, then using short(er) filenames should solve your problem.

Dear bdpg

As I don´t know what the code is doing changing the names is not working. For which files shall I change the name, which part of the name?

Hi @tanimbar ,
have you managed to solve ur problem ? I have wind10 and I am having the same problem with sen2cor L2A process. Please let me know how did you solve it if so!

Thanks alot, D

Hello Daniel1,
No, I haven’t solved the problem but I didn’t try either (well, not much).

I’m in no hurry, so will simply wait until the issues are fixed.

Thanks for the update @tanimbar!

Dear all

I manage to solve my problem. I had to uninstall everything, including Anaconda and SNAP. I re-installed everything again following exactly the instruction, including the part where Anaconda is python 2.7 default (which by the way made my QGIS inoperable).
The same black window appeared. I then confirmed all paths in the edit SEN2COR tollbox and the SEN2COR_HOME path was not correct. I changed to the default.
After that I still come across with an error in the SEN2COR processing window. It turns out there was a wrong path in the Anaconda2\lib\site_package\sen2cor-2.2.1-py2.7.egg folder. The folder cfg was not there but inside another folder sen2cor. I’ve copy cfg folder and put it inside sen2cor-2.2.1-py2.7.egg and now it is working, including processing 10m images.
I hope it helps.

Dear all,

I have a similar issue however it is not resolved by the above fixes. I am running the program on Windows 7. I had a similar issue with the wrong path for the \Anaconda2\Lib\site-packages\sen2cor-2.2.1-py2.7.egg\sen2cor, I then copied this to here: \Anaconda2\Lib\site-packages\sen2cor-2.2.1-py2.7.egg and this time command prompt states the program has started but does not do anything. When run through SNAP the issue that the display window remains totally black and nothing happens.
I have now tried all the above, including moved directly to C: to reduce filenames and created a PYTHON_BIN as a system variable. Are there any other potential solutions?


Hallo Creil,

You must keep short the name of the selected input product including the path. Copy your L1C-file near to the root-directory of your drive. Keep ‘S2A_OPER_MSIL1C’ of your input file. I delete/rename the acquisition time which is doubled at the end of the filename coming to product file name like ‘S2A_OPER_MSIL1C_R065_V2015-08-06-T1020.SAFE’. All what I deleted is kept in the name of the xml in the root directory of the L1C-product which I don’t change.

Kind regards

Deutsches Zentrum für Luft- und Raumfahrt (DLR) - German Aerospace Center | Earth Observation Center | Remote Sensing Technology Institute | Photogrammetry and Image Analysis | Team Marine Remote Sensing | Rutherfordstrasse 2 | 12489 Berlin | Germany

Bringfried Pflug
Telephone +49 30 67055-655 | Telefax +49 30 67055-642 |