I downloaded and am using sen2cor2.10.01. Applying the topographic correction I did not encounter problems with the S2 images acquired in Italy while I can not correct the images acquired elsewhere. I tried with images captured in South America or Africa. The error is this: “[Error 32] cannot access the file because it is used by another process: '… GRANULEL2A_T19JFN_A028650_20201216T143730tmpcwqrissrtm_L2A_T19JFN_A028650_20201216T143730_src.tif.”
I tried to use the previous versions: the 2.9 comes out with the same error, the 2.8 works correctly. For the boobs I used the same DEM: SRTM 90m resolution.
Can anyone explain to me how to correct the error?

Dear Sergei,
thank you very much for your help. Yes, if the sentinel2 image falls entirely on an SRTM tile, then sen2cor2.10.1 is working fine. On the other hand, if the sentinel image occupies two or more tiles, then sen2cor2.10.1 exits with error code [error 32] etc. etc. I tried to merge the SRTM panes where the Sentinel image falls, as yuo suggested, but the error remains … …

I apologize for misleading you!
One solution was found and reported in Processing Error due to SRTM Data Conflict by vicencpala

Dear Sergei,
thank you very much for your persistence! Your last suggestion works well.
Best reguards