Slave band generated by BackGeocodingOp is empty

Dear developers,

We experience problems with the BackGeocoding operator in the SNAP2.0 release. When using this operator on a ProductSet-Reader the slave bands being returned are empty. Please see the attached XML for reference (Note that the two BEAM-DIMAP input files used have already been through a TOPSAR-Split and Apply-Orbit step).

Any feedback/help would be appreciated.

Best regards,

test09122015.xml (1.9 KB)

Have you tried backgeocoding on its own without the graph? It might have something to do with the subset. Is the data within the SRTM ±60 area?

Checking the provided xml shows that the data is indeed within SRTM ±60.

Hi @lveci,

Like @SvH said, we are within SRTM±60. I Just tried to run without the SubSet in the snap GUI (see XML attached) but the slave bands remain empty.

myGraph.xml (2.2 KB)

Hi @lveci,
We also tried to do BackGeocoding directly via the GUI menu. In this case we do get data in the slave bands.
To conclude, it seems that there is an issue with the BackGeocoding operator used via the gpt.
Could you please open a bug report for this issue so that the corresponding developers can look into it?

Thanks a lot,

The main problem is that you are using SRTM 1 sec Grid which does not auto download. You need to have all the dem tiles in Arc Grid format.
Please use ‘SRTM 1Sec HGT’ and even then be careful about the coverage since most of the Middle East and some of Africa, Russia, Turkey, Greece are not covered. See here.

Also, your graph looks like it’s from S1TBX 1.1 Although it works, I would recreate any graphs in SNAP 2 to make sure any missing or renamed parameters are present. backgeocoding-productset.xml (2.1 KB)

The most recent release of SRTM 1 second covers the whole world - you may want to update your copy.