SNAPHU Unwrapping

Hi all,
I tried snaphu phase unwrapping of ALSOPALSAR data, but I faced this problem;
Logging run-time parameters to file snaphu.log
segmentation fault

Have anyone an idea?

I once found this, I guess it is still valid:

An explanation is given here:

This is caused by ctime() function in src/snaphu_io.c file [1]. To solve this problem, edit this file, change “#include <sys/time.h>” into “#include <time.h>”, and then compile and install again [2].

1 Like

Thank you for your reply, but I tried this and faced the same problem

snaphu v1.4.2
27 parameters input from file snaphu.conf (84 lines total)
Logging run-time parameters to file snaphu.log
Segmentation fault

Can you clarify your solve more, please?

as it is not my solution I cannot provide any help, sorry.

1 Like


How I can obtain Digital Surface Model (DSM) from Sentinel-1 SAR data?

please have a look at this topic:

Thank you!

who can help my about this error in Unwrapping by SNAPHU ? -Unexpected or abnormal exit of child process 2594-

I am trying to use snaphu to unwrap my data, too. but the following appears after running
Unwrapping tile at row 4, column 7 (pid 2977)
Unwrapping tile at row 4, column 8 (pid 2978)
Unwrapping tile at row 4, column 9 (pid 2979)
Unwrapping tile at row 5, column 0 (pid 2980)
Unwrapping tile at row 5, column 1 (pid 2981)
Unwrapping tile at row 5, column 2 (pid 2982)
*** Error in `snaphu’: corrupted size vs. prev_size: 0x00005585095fd840 ***
Unexpected or abnormal exit of child process 2977
PL help me

You should attempt to modify the correlation coefficient in the SNAPHU Import , and then run again.

hi, i,ve been finished the process, as you can see from the picture, i got the color dimension in abs_phase, but i saw from the other posted some people got into length dimension unit (meter). so how can i get that unit dimension. moreover, does anyone here have information how to analysis for subsidence suppose.

i will pleasure to know the anwers
thnk you

i resolved it
otherwise i have another question, why the elevation on the land has number minus (-200 till - 500)?
does it right?

You can right click on your band and say > add elevation band to compare it with SRTM 1 ArcSec 30m data.
You probably have to check the coherence layer for areas with low coherence (> 0.3). For this pixels, height estimates are not of good quality (probably the ones in the lower part of your image).


I have some difficulties with phase unwrapping of TerraSAR-X data (2 images with 11 days temporal baseline).
Using SNAP I made the following processing:

  1. DEM Assisted Coregistration of 2 TSX images.
  2. Range Filtering.
  3. Azimuth Filtering.
  4. Interferogram formation.
  5. Subset of the AOI.
  6. Topo Phase Removal (using ASTER GDEM, 30 m resolution, 2011 - this is the only DEM available for this region).
  7. Goldstein Filtering.
  8. Snaphu Export (DEFO / MCF).
  9. Unwrapping using Snaphu.
  10. Snaphu Import.

The wrapped phase is fine, the coherence for the most parts is acceptable but unfortunately the unwrapped phase looks incorrect.
I also made the processing of Sentinel-1 images for the same region and using the same DEM and it worked OK.
Could you please help me to find out where the problem is.

Thanks in advance!

Hi ABraun,

I had the same issue “Unexpected or abnormal exit of child process” and this suggestion worked like a charm. I am puzzled though, as I cannot explain to myself why this would make such a difference. Seeing as how you suggested it, can you (or anyone else for that matter) provide a (short) explanation of why altering row and column specs makes a difference to SNAPHU?

Thank you kindly!

I believe it is a thing of adding up the cumulative phase values. If snaphu operates in these tiles, maybe the tile boundary is not suitable for the algorithm to start or end. But I’m not experienced enough to tell the exact reason.

How can you perform step of snaphu exporting and unwarping?
Is it nessecary to install linux?

no, the latest version of snaphu is windows compatible and standalone.

Please see this video from 4:40


Hi dear,can you pls explain me, how did you perform unwarping using windows? Can i perform snaphue exporting without using linux?

snaphu works with windows, please see the other topics and the video I poseted above: