SRTM ZIP-files are corrupted or not found

same problem…???

I think snap’s ability to open zip files is broken since yesterday (or so). We get the same error on the “” file (the data for the EGM96 gravitational model):

2020-12-05T19:15:15.651809346Z INFO: http retrieving
2020-12-05T19:15:15.651816240Z error in opening zip file                            
2020-12-05T19:15:15.651823153Z 90% done.                                                                                               
2020-12-05T19:15:15.651829433Z org.esa.snap.core.gpf.OperatorException: error in opening zip file

Downloading and unzipping that same file locally works perfectly fine, though…

@lveci could you please have a look?

Dear s1tbx team,

I get this error when computing interferogram using SRTM 1Sec HGT:
SEVERE: org.esa.snap.core.dataop.dem.ElevationFile: error in opening zip file
INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving

I tried to access the link, and find the file, but I didn’t find.

Thank you in advance for your attention

I’m processing interferograms with SLC products from sentinel 1 A, referring ≈ 1 year (7/26/2019 - 6/26/2020).
I’m using SRTM 1Sec HGT in Back-Geocoding and TopoPhaseRemoval.

7 posts were split to a new topic: SNAP searches non-existent SRTM tiles

I merged all topics dealing with this error.

1 Like

And orbit files are also affected:

WARNING: org.esa.s1tbx.sar.gpf.orbits.ApplyOrbitFileOp: error in opening zip file
WARNING: org.esa.s1tbx.sar.gpf.orbits.ApplyOrbitFileOp: ApplyOrbit ignoring error and continuing: error in opening zip file

Apparently, everything in snap that downloads a zip fails (it creates a corrupt zip file).


I would like to know if these issues are related with downloads made on 3 or 4 December nights, when STEP server was upgraded and restarted or if this still happens with downloads made today.
Thank you for this clarification.

FYI: It seems things have been fixed now. Preprocessing (including apply orbit file and download of EGM96 zip) works ok again here. Did not test the srtm tiles, as we’ve cached those ourselves to not hammer esa’s servers too much. Thanks for the fix!


@vincentschut thank you for you feedback!

A post was merged into an existing topic: Snap Error in opening zip file

2´ ago I was processing Sentinel-1 GRD products using SRTM 1sec HGT and running!, but when I use SRTM 3sec GHT it doesn´t run. I am not sure if my results are good :grin:

Interesting, I have the same issue with ACE30 and GETASSE30. Orbit file downloads without issue though. No issues are present in desktop SNAP

Hallo @ABraun, I am facing the same problem. I am doing an urban footprint with SLC-Product so I am creating the Terrain Corrected image to use for computing the coherence. I am using the ESA Tutorial with the steps: split-orb-cal-deb-ML and finally the TC. I was trying with SRTM 1sec and also as default SRTM 3sec and all the process stops by writing ~20% and doesn’t want to finish the processing at all. Last time it worked was Monday or Tuesday. Then suddenly this bug.
I was using SNAP v8 and v7 for Windows because I thought going to the previous version would be a temporal solution… but no. And also today I switched on my another laptop with the versions for Linux and same story.
Is it possible the issue comes from some SNAP update by ESA? Can’t be it worked fine with same data with same settings and after Monday/Tuesday it suddenly isn’t.
Would be really nice to find out the solution for this problem as soon as possible. Thanks in advance. Greetings.

This happened after the release of SNAP 8, but something has changed - maybe the access to the SRTM data. @mengdahl @lveci
We are currently looking into this.


Hello, I am still experiencing this issue, do you have an ETA on resolution? Thanks.

have you tried SRTM 1Sec instead?
You can also try this: Gpt sentinel-1 back-geocoding error

This solved my issue, thank you for the quick response and have a great Christmas.

1 Like


This issue occurred because the location of SRTM 3Sec (AutoDownload) has changed, so SNAP is no longer able to retrieve it during Terrain Correction, Back Geocoding, Topographic Phase Removal ect.

As a solution:

  • switch to SRTM 1Sec HGT (AutoDownload) or
  • change the location of the data as described here

This will be fixed with the next SNAP update, so please keep your version updated (Help > Search for Updates)

1 Like