SRTM ZIP-files are corrupted or not found

Hallo @ABraun, I am facing the same problem. I am doing an urban footprint with SLC-Product so I am creating the Terrain Corrected image to use for computing the coherence. I am using the ESA Tutorial with the steps: split-orb-cal-deb-ML and finally the TC. I was trying with SRTM 1sec and also as default SRTM 3sec and all the process stops by writing ~20% and doesn’t want to finish the processing at all. Last time it worked was Monday or Tuesday. Then suddenly this bug.
I was using SNAP v8 and v7 for Windows because I thought going to the previous version would be a temporal solution… but no. And also today I switched on my another laptop with the versions for Linux and same story.
Is it possible the issue comes from some SNAP update by ESA? Can’t be it worked fine with same data with same settings and after Monday/Tuesday it suddenly isn’t.
Would be really nice to find out the solution for this problem as soon as possible. Thanks in advance. Greetings.

This happened after the release of SNAP 8, but something has changed - maybe the access to the SRTM data. @mengdahl @lveci
We are currently looking into this.


Hello, I am still experiencing this issue, do you have an ETA on resolution? Thanks.

have you tried SRTM 1Sec instead?
You can also try this: Gpt sentinel-1 back-geocoding error

This solved my issue, thank you for the quick response and have a great Christmas.

1 Like


This issue occurred because the location of SRTM 3Sec (AutoDownload) has changed, so SNAP is no longer able to retrieve it during Terrain Correction, Back Geocoding, Topographic Phase Removal ect.

As a solution:

  • switch to SRTM 1Sec HGT (AutoDownload) or
  • change the location of the data as described here

This will be fixed with the next SNAP update, so please keep your version updated (Help > Search for Updates)

1 Like

I have updated snap version where there looks to be the new directory for the strm but am now getting the following error.

INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving
INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving
SEVERE: org.esa.snap.core.dataop.dem.ElevationFile: java.lang.reflect.InvocationTargetException
INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving
INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving
SEVERE: org.esa.snap.core.dataop.dem.ElevationFile: java.lang.reflect.InvocationTargetException

Same problem here. Our python script returns:

INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving
SEVERE: org.esa.snap.core.dataop.dem.ElevationFile: error in opening zip file

The SRTM 3 Sec data are no longer located at the cgiar-csi server, so SNAP can no longer access them. This affects

  • Range Doppler Terrain Correction
  • S1 BackGeocoding
  • Topographic Phase Removal
  • Orthorectification
    as long as SRTM 3Sec (AutoDownload) is selected.

A new location has already been implemented, but the latest update does not yet cover all cases.
To go sure, please test one of the suggestions below unil this is covered by the next update.


Please update SNAP (Help > Check for updates), the latest update (8.0.3) fixes the error.

Work around

Select SRTM 1Sec HGT (AutoDownload) as DEM instead.

Manual solution (no longer required)

  1. Go to your SNAP installation directory (e.g. C:\Program Files\snap) and go inside the ect folder where you find the file
  2. Open it with a text editor (maybe needs administrator privilleges) and go to line 27 which defines the location of SRTM 3Sec data. Change it from
    DEM.srtm3GeoTiffDEM_HTTP =
    DEM.srtm3GeoTiffDEM_HTTP =
  3. Save the file and restart SNAP.

It has also been reported that deleting old DEMs downloaded into the user directory helped after changing the data source. This means to remove all files inside:
user\.snap\aux\dem\SRTM 3Sec
especially the ones which are only 1 KB. Otherwise, SNAP tries to re-use them in the future, but they are empty.


Thank you for sharing this solution.
I am using SNAP 7.0 and this solution worked without the wildcard * at the end of the line.


1 Like

thank you, the * was not intentionally placed there, I removed it.

This is still affecting many people who have reported issues in this forum. I know from experience that there are many more who don’t report the issue and may flail around with re-installs, trying different OS’s, adding memory, etc. Some non-reporters will look to documents such as the FAQ, so it could help to add an entry on what to check when a job takes too long.

Some questions:

  1. How do you check whether a workflow other than Terrain Correction, Back Geocoding, or Topographic Phase Removal uses SRTM 3sec files?

  2. what does SNAP do with invalid .zip archives? (The ~/.snap/auxdata/dem/SRTM 3sec folders on one system I checked contained many invalid .zip files. )

  3. should users take steps to remove invalid .zip archives?


these are very good suggestions, thank you. I hoped that this can be resolved within a small update and is fixed within the next days, but depending on the response of the developers we might take more action to guide users which struggle. A temporary FAQ entry is a good idea!

I created a FAQ entry here: A process related to digital elevation models is taking forever to finish

Did I miss a crucial point?

Excellent FAQ entry. Hopefully it will reduce the stream of forum posts on the topic as well as reaching some who won’t post for various reasons like lack of confidence when writing in English.

Thank you for your support.

I did the same methods, but the changes are not saved.
Can you help?
thank you

2021-01-24 12_55_30-snap.auxdata - WordPad

@shahin.jafari75 Please check here:

I tried both, but it still didn’t work.

can you please specify what exactly did not work? Were you able to change the file? Have you tried SRTM 1Sec instead? What happens?