Subset not working and the button even cannot be clicked

Hello(,・∀・)ノ, I just downloaded SNAP7.0 and find that Raster->Subset not working, specifically, the button even cannot be clicked.
The data I use is S1B_IW, could anybody please help me out, just tell me how it happened or how can I solve it(╥╯^╰╥)?

Hi @geoyayaispoor,

Try to first select the product you want to subset in the “Product Explorer” panel, it should enable the Subset action.


1 Like

Hello, thanks for your answer ♪(・ω・)ノ. I can execute subset nowヾ(@^▽^@)ノ, however, there is no image on spatial subset window and a red line word from the lower right corner says,’ Estimated, raw storage size: 1137.8M’

I tried to select a zone randomly and applied subset button, it did work and after that that random smaller one(about 530M) finally show it’s image. Is that mean from now on, if I wanna see the image from my data, the only useful way is keep it 1G below?

And there is one thing still confuse to me, actually I have about 7.93G RAM, it should have worked[・ヘ・?].

usually, this window pops up in the subset dialogue


and it takes a considerable while until the preview is displayed, even on fast computers. Please give it a try and wait for several minutes to see if the preview comes.

Hello, sorry to bother you again(╥╯^╰╥). Still no image and addtionally one error occured, named ‘java heap space’. _(:з」∠)_Are fast computers occured that?

I’ve used tools->option->system window->compute to get good settings for my computer and executed again, however, still came to ‘java heap space’.o(╥﹏╥)o

java heap space indicates that your memory cannot handle this task.

If you want to clip a specific area, you can also generate a WKT here:

Then use the Subset operator in the graph tool (here you enter the WKT) to execute it:

1 Like

Thanks♪(^∇^*), it worked♪(・ω・)ノ