System configuration


I am facing issue in processing RADARSAT2 data with SNAP 5.0 . could some one let me know, what is the minimum system configuration to work with SNAP…!

My system configuration is :

Processor: Intel core i7
OS: Windows 8 - 64 bit…

It would be helpful to know a bit more about the ‘issue’.
Do you get an error message, for example? At which step?
Do you process multiple images (batch mode, for example)? For a single Radarsat-2 product 8 GB should be sufficient. It depends on the imaging mode, though. Which is yours?



When I try with sample RADARSAT 2 data provided with tutorial from the link:

noticed that SRTM 3sec data is downloading automatically for sample data set when running graph. and processing successfully without “Negative pixel spacing in snaphu”.

I am working with Radarsat 2 - MF22 - SLC - HH polarized data .

The main error I am facing is after exporting to SNAPHU, in snaphu.config file - the pixel spacing is negative value and this resulting error while executing snaphu command in linux is

"27 parameters input from file snaphu.conf (84 lines total)

pixel spacings dr and da must be positive (meters)"

I have the problem statement with the topic here:

I am not sure that error is occurring with auto download DEM and executing the step TopoPhaseRemoval…

I tried with applying aster 30m DEM as external DEM as well. But no change in result.

I am working with Radarsat 2 - MF22 - SLC - HH polarized data for two dates.

I’d say this is not a hardware error then.

Can you open the snaphu.conf file and have a look at the values of the pixel spacing?

Slant range and azimuth pixel spacings
DR -2.6623568
DA 2.8336656

Single-look slant range and azimuth resolutions.

RANGERES -2996948.7732627
AZRES 2.5165826

did you try removing the - and re-run snaphu?

when - is removed, It is executing without that error in Linux.

I would like to know why -ve values are coming in snaphu.config. when i run graph with my data set.

It will be helpful for future analysis…

what do you mean with -ve values?

Can you share your graph please ?

It means negative value (-ve value)

Graph can be found in the same conversation through link to another topic

maybe the negative pixel spacing originates from the location of the study area. Is it located south of the equator?

Did you try other images ?

For the “operator exception” maybe the problem come from the DEM because of the format “.tif”.

Can your share your RS2 images ?

It is located to North of equator…

Dear Sadri,

I can’t share RS 2 images. I have tried with sample data set, it is working fine without error.

If manual choice of DEM is the problem, I tried with auto download option as well. but no change in result…

Yep I tried with the sample you give through the tutorial and it works also fine for me.

If the auto download DEM give the same results I think the problelm remain in your image…maybe something is corrupt.

Try to make some operations on your image involving the dr and da (like SRGR for example) and try an onther images pair if you have some.

Keep us posted :slight_smile:

Hi Sadri,

Could you let me know, what are operations can be performed in detail to remove those errors…

Ortho rectification / Georectification is required in this case …?