TanDEM-X bistatic CoSSCs error in SNAP

Hi ABraun

It worked now! Many thanks for your help. :slight_smile:

For CoSSC, it should be able to open the TDM …xml in the root folder which will include the two sub products into one.
Sometimes if the path is too long it could have trouble opening the product in windows.

Hi lveci,

I think this was one of the problems, the long path.
I did a test right now reducing the path and it worked perfectly.

Many thanks :slight_smile:

Hi all,

I got a similar error as well. I am working with TanDEM-X data from 2011 to 2015 (CoSSC-data). Snap won’t read data of the year 2015 (09/08/2015). The other years worked very well. I got the error message as shown in the figure below. Any ideas on the problem I have?
I hope for answers.

Cheers Bjoern


Try to unzip again the original file and test. Also check if the folders TDX and TSX inside of the main folder have the .xml files. In one of my images, the .xml files was with problems so I unziped again and it worked well.


Thanks for your reply. I tried to follow your suggestions but the error still remains. As your error is slightly different to the one I got, I opened a new thread for finding a solution regarding the
java.lang.NullPointerException error.
You can follow the discussion here:



Would you guideline the steps TanDEM-X data to sigma0?

Radar > Radiometric > Calibration

Read > Calibration > Terrain-Correction >write
I got error said
“Error: [Nodeld Calibration] Cannot apply calibration to coregistered product”

that is true, calibration comes before coregistration. You can open both images separately, calibrate them and then create a stack of both calibrated images.

What you mean “both images separately”?

TanDEM-X consists of two images. Each of them is a TerraSAR-X image which can opened individually in SNAP.

I separated and still got error

don’t create a subset. Import both files individually by File > Import > SAR sensors > TerraSAR-X and select the XML files within the two data folders, not the XML in the top folder.

Thanks, it worked now, but too noise!!! I applied the Thermal Noise Removed but can not apply for TanDEM-X. Any suggestion?

please show screenshot what you mean by noise.

What are you trying to do with the data?

Please see screenshot

This isn’t thermal noise and probably related to speckle and surface characteristics.
Does the image look better before calibration?

No, they are the same, too noise. The tanDEM-X can not use the Thermal Noise option, they are not available.
So what do you suggestion? apply the speckle after Terrain Correction?

yes, filtering could reduce this effect.