TanDEM-X DEM results not good

Dear Friends,

I am not sure what happened with the results of my TanDEM-X DEM processing. My worksteps are as following:

  1. Subset
  2. Interferogram formation
  3. Goldstein filtering
  4. Multilooking
  5. Export to SNAPHU
  6. Unwrapping in SNAPHU
  7. Import from SNAPHU
  8. Phase to Elevation
  9. Range-Doppler Terrain Correction (TCL)
  10. Eport --> DEM/DSM

Please see below the results below. Thank you

a first step would be to check the interferograms before unwrapping. If their quality is bad, the result will also be bad.

The additional lines at the edges are sometimes introduced by intermediate steps. You can remove them by a subset before proceeding with the next step (difficult after terrain correction).
Explained here: DEM generation with Sentinel-1 - Workflow and challenges
(Figure 20).

The rectangular shapes are rather artefacts of the unwrapping, so differnt tile sizes might be a solution here. Some comments on artefacts are given in the mentioned tutorial on page 26.


Thank you for your reply and clarifications.
Page 26 sums it all i think so that I can work around to fine tune each settings in my workflow.
have a nice day!


Dear Professor Braun,
I followed your suggestion as in page 26 increase the
" Degree of flat-earth polynomial, increase the Number of flat-earth estimation points & increase the Orbit interpolation degree", but my 2015 data keep giving me the “trend (ramp)” results. Please advice what else I can do to get it right.

Thank you

TanDEM-X orbit files are of good quality, so this parameter should not make the largest difference actually. In your case, a ramp was introduced because the orbit information was probably over-fitted, a lower value should be more suitable here.

How does the interferogram look with standard settings?

Dear Professor Braun,

Now I have tried both higher and lower value number of the three settings in the processing parameters. The results still the same. Please clarify the meaning of this “ramp was introduced because the orbit information was probably over-fitted” or give me any link to paper so that i can read and understand this.
With standard settings also same result.
Please advice, thank you

It’s all about how orbit files work.
InSAR requires accurate information on the position of the satellites at the time of acquisition. Orbit state vectors in the metadata don’t have continuous position information, but at regular intervals. If the image was acquired between position x and y, the method of orbit interpolation determines how the oposition in between is estimated.
Sensors such as TSX or Cosmo SkyMed have very accurate information so there is usually no problem in high interpolation degrees and increasing them potentially leads to even better results.
In other cases, like ERS for example, orbit information can contain noise so higher interpolation degrees can over fit these false positions and make results worse. Accordingly, lower degrees can level out these errors.

To make it short. There is no ideal setting which works for all, therefore SNAP allows to adjust these parameters, but their effects have to be understood.

The ramp in your interferogram indicates bad coregistration quality. Have you tried loading both products separately and coregistering them yourself?

Please also have a look at other topics discussing ramps in TanDEM-X data

I’m not a professor by the way but thank you for your politeness.

Dear @ABraun

Thank you for your lengthy explanation. Will need time for me to understand and figure out the solution.
You are teaching a lot of people here in this forum that’s why Im calling you Professor (Sensei) for the respect on your valuable knowledge.
I haven’t try the coregistration.
I will ask you more questions soon.