Terrain flattening co-registered images

I am running into trouble performing Radiometric Terrain Flattening on co-registered images, wondering if anyone else has run into (and has a solution to) this problem?

My images are first calibrated to beta0 and co-registered, but when I continue in the processing chain to terrain flatten the image with two beta0 bands (a master and slave), the output image has a singular gamma0 band, with no indication if it is based on the master or slave input band.

Anybody familiar with this?

Wouldn’t it make more sense to coregister after flattening?

Thank you @ABraun for the input. Co-registration after multi-looking and terrain flattening still results in minimal residuals.

are the bands still empty if co-registering is performed last?

I may not understand your question; originally my issue was in terrain flattening co-registered images with multiple beta_0 bands. This process would produce a single gamma_0 band, and didn’t indicate if it was a flattened image of one of the bands or a combination of the bands.

Terrain flattening prior to co-registration solves this problem, and thankfully produces minimal residuals.

As the best DEM’s I have access to for this region are the S1-tbx available SRTM or ASTER, I still must multi-look before terrain flattening, which is more processing than I would prefer prior to co-registration.

Disable the re-grid option and you can flatten without multi-looking.

I have also tried terrain flattening prior to co-registration but still I have missing bands in the outcome image, I think it is the problem of the stacking phase in co-registration because when I stack the images using create stack option I have the same error.

In this topic I have shown the error

It looks like the current Terrain Flattening code has some problem in handling target product band names. We will fix it. Thank you all for pointing it out.

The problem has been fixed.

Thanks for the update. Is it in the new version?

It should be in the next release (somewhere in June)

Thanks for your responses, @ABraun.

When I disable the re-grid option, at least using the SRTM 1 arc-second DEM, my resulting image is replete with blank sections, as shown below:

Terrain flattened image before multi-looking, re-grid option unchecked

Same terrain-flattened image, with multi-looking and terrain correction performed

I’ll explore now whether I see the same effect using the ASTER GDEM. Has anyone else run into this issue?

it could be that artefacts in the DEM cause strange holws. Would be worth a try with the ALOS World DEM

I don’t believe the blank sections are due to DEM artifacts. Below are similar results with the ASTER GDEM and ALOS DSM:



FWIW, the SRTM 1 arc second DEM performs generally quite well when multi-looking is performed before terrain flattening. Have you experienced otherwise in your processing?

reminds me of this

Here, also small DEM errors caused large faulty areas.