Updates unavailable?

I have recently uninstalled and reinstalled SNAP v8.0. I keep getting a note that Model update v8.0.3 has been released. Please update! Plus I get a large shopping list plugins to update. Yet whenever I try, the Downloading plugins progress bar never gets above 0% and I get an error that “Not all of the plugins have been successfully downloaded. The server may be unavailable at the moment. Try again later.” This has been going on for a few weeks now, plus I get random slowdowns.

My colleagues and I have had similar problems (also in Canada). The Netbeans offline install process worked well for us.

I’m sorry to hear this.
It seems that most people can update SNAP.
We do not exclude Canada from the updates. So, what could be the issue?
Have you tried to update SNAP within a different network? This might be network issue.
Or a proxy must be defined?

@lveci You’re also in Canda. Have you noticed some issues?

@oana Could you have a look at the server?

Regarding the server, no heavy traffic noticed lately.
It works quite well here.

In the past my colleagues at the Bedford Institute of Oceanography in Nova Scotia and I had problems with NASA Goddard servers. This due to anti-DOS measures that block IP’s making “too many” requests in a short period and a firewall configuration using a single external IP for multiple groups across multiple departments. Our IT people worked with NASA to implement an “undisclosed” fix. Nova Scotia often has better network connections to Europe than to the US, but now there is a Government of Canada Network for which seems to reach the US via Ontario. As I’m retired and working from home, my access to the GoCN is uses a VPN. I do most downloads using my home network without VPN and have few problems if I avoid peak Netflix hours.