Wierd values around my colored image from SNAP to QGIS

Dear all,

I made an image by using band math in SNAP, I had some area around of my image that had value of (-3.906) (figure 1), so I used NON (figure2), then they are converted to ‘NaN’ (figure3).




But when I open it in QGIS, at first, it does not have that value in image (figure4) but when I used (properties……singleband pseudocolor….apply…ok) (figure5), then again I have those value in blue color around of my image (figure 6).

Figure 4


Would you please let me know, what can I do to remove it around of my image in qgis?


Dear Marjan Marbouti,

In the transparency tab you can select a value for “nan”.


My value that I made NAN in SNAP was (-3.906) but its value in here is (-1.163920) that it has some pixels in my image too and I do not know how can I remove it by transparency?

As you can see in below image, if I want to transparent all pixels with blue values, then blue pixels in image will be disapeard too.

use the identify tool to retrieve the exact value of the blue areas and then enter it under transparency.

Sorry,where is the identify tool?

I used it but it did not show me anything.

It is strange because I made it NaN in SNAP (Figure 1).


And also you can not find that value here (figure 2)

Figure 2

But we still have it in image in QGIS and I think it is mixed with some pixels in image (figure 3)


to see the actual value you have to scroll towards the right.

Min/Max in the raster properties do not matter, they are not the actual smallest values. As you selected “cumulative count cut”, these are 2% afar from the smallest and largest values in order to enhance the contrasts.

The value is ‘nan’ (figure 1).

I tried to make this value transparents but I think in transparensy tap, it only accepts numbers, not ‘nan’. (figure2)


the only thing I can suggest is to make sure that the actual raster is selected in the table of contents before using the identify tool. Otherwise you will extract the pixel value of any other raster which is currently loaded into the project).

Have you tried entering: From -50 to -1.75 (or something outside the legend) in the transparency range?

I am sure that the actual raster is selected.
I choose between (-50 ) to (-20). (figure1)

but the result is like below (figure2)


@ABraun…It worked :grinning:…I choose between (-50) to (-20) and also chose ‘none’ instead of ‘band1’. It is OK but I do not know why.

good to hear!