Workflow between SNAP and StaMPS

currently, I think this is not supported by snap2stamps

mt_prep_snap 20200326 /media/sadi/WORKDIR/INSAR_20200326/ 0.4 12 4
after running this step successfully, I am getting this error.

Try this,

Thank you for your help. I have tried as per your instruction with ps_load_initial_gamma.m (7.2 KB) file. But now I am getting this error.
kind regards,

image

Had you checked if you have the file rsc.txt on the main INSAR_masterdate folder?

I am sorry I missed that file. But after pasting that file I got the previous error again. image|488x424

Can you please tell me that I am using the right directories or not.

The matlab folder containing the scripts is sufficient, your working directory is set in the GUI directly

Thank you for your response Sir.

I am on the step stamps(1,1) but all the time I am getting same errors,
Index in position 2 exceeds array bounds.
Error in ps_load_initial_gamma (line 108)
*rg=rgn+ij(:,3)rps;
Error in stamps (line 263)
ps_load_initial_gamma;

I have tried it by replacing my ps_load_initial_gamma.m (7.2 KB) file. I have tried 0.4 1 1 ; 0.4 2 2; 0.4 12 4. all values for mt_prep_snap.
I have few questions:

  1. My interferogram was wrong so I delete it and delete the data in the stamps export folder related to that date. Is it right? Or I have to do all stamps_export again for the all remaining data?

  2. Kindly tell me these interferograms are correct or wrong?

  3. Any other solution to correct this error?

Thank you so much I am new to Linux and Stamps. This forum is helping me a lot.

I think deleting faulty interferograms might cause problems later so I advise to recompute them in SNAP and check of they look alright before you do the StaMPS export. The second and third intererograms are corrupt, one has missing data, the other doesn’t contain phase information of both dates. Probably already the coregistration failed. Please be aware that three interferograms are not sufficient for StaMPS, especially when they look as noisy as the ones shown.

I am using 55 interferograms in total rest are all fine. these three are the ones that I feel are wrong.
So should I just skip these three interferograms. And go for the last step of snap Stamps_Export for the rest of my 52 interferograms? or I need to repeat the whole process of SNAP from first step of coregistration?
Thank you so much Sir for your time.

Alright, sorry for the misunderstanding.
If you manage to remove these from the stack and then export the remaining ones, it could work.

Thank you. I will go for it.

Greetings! I have completed my stamps export and the run stamps(1,1), (2,2) & (3,3) successfully. but in the case of stamps (4,4) every time I run this command after

Matlab crash without any prior notification every time. As I am not getting any error I am unable to get what is the problem. I have enough memory to run all the stamps steps in my drive. I have update my java. But still facing same problem. Kindly guide me what expected cause of it.

Thank you so much in anticipation.

Step 4 is unwrapping, is snaphu installed correctly?

You appear to be using linux, but don’t mention a distro and version. Do you see something like:

“MATLAB has encountered an internal problem and needs to close” with options to send information to MathWorks, attempt to Continue, see more details, or ‘End Now’ to closing the program?

Matlab has debugging tools such as running a script one step at a time that should help pin down the source of the problem.

Yes Sir! @ABraun Snaphu is installed correctly. and @gnwiii I am using ubuntu 20. 04. I got this error once or twice when I was working on Matlab. but in this case for step 4 I am not getting any error. it just ends on its own without prior notification.

I got this report but I am unable to solve the issue even then. your kind help will be appreciated that how to solve it.


   Segmentation violation detected at Sat Jun 19 00:38:49 2021 +0500

Configuration:
Crash Decoding : Disabled - No sandbox or build area path
Crash Mode : continue (default)
Default Encoding : UTF-8
Deployed : false
Desktop Environment : ubuntu:GNOME
GNU C Library : 2.31 stable
Graphics Driver : Unknown software
Java Version : Java 1.8.0_152-b16 with Oracle Corporation Java HotSpot™ 64-Bit Server VM mixed mode
MATLAB Architecture : glnxa64
MATLAB Entitlement ID : 6257193
MATLAB Root : /usr/local/MATLAB/R2018b
MATLAB Version : 9.5.0.944444 (R2018b)
OpenGL : software
Operating System : Ubuntu 20.04.2 LTS
Process ID : 2737
Processor ID : x86 Family 6 Model 78 Stepping 3, GenuineIntel
Session Key : 24033645-3378-447c-a803-d921c793f6d0
Static TLS mitigation : Disabled: Unnecessary 1
Window System : The X.Org Foundation (12009000), display :0

Fault Count: 1

Abnormal termination

Register State (from fault):
RAX = 00007fa1687fcd10 RBX = 00007fa168b5a400
RCX = 00007fa11f56cb30 RDX = 0000000000000000
RSP = 00007fa11f56cb28 RBP = 00007fa169700bf0
RSI = 000000001000e652 RDI = 00007fa168b58b10

R8 = 0000000000000014 R9 = 00007fa135df85f0
R10 = 0000000000000014 R11 = 000000001000e652
R12 = 00007fa16901fd84 R13 = 0000000000000001
R14 = 0000000000000001 R15 = 0000000000000014

RIP = 0000000000000000 EFL = 0000000000010202

CS = 0033 FS = 0000 GS = 0000

Stack Trace (from fault):
[ 0] 0x0000000000000000 +00000000
[ 1] 0x00007fa135df8645 /lib/x86_64-linux-gnu/libpango-1.0.so.0+00210501
[ 2] 0x0000000200000004 +00000000

You should report this to Matlab. They may already have a solution, if not they may ask for a minimal example that demonstrates the bug.

Thank you for your response, I will do it.