Workflow between SNAP and StaMPS

For PS calculation you need snaphu (for unwrapping i.e., stamps(6,6)), Trian (for atmospheric correction i.e., stamps(8,8)), and Matlab are mainly required.

Better first read the StaMPS manual, there you will get maximum answers.

Thank you for your help. Thank you very much.

1 Like

Please read this below one, for a better understanding of StaMPS.

StaMPS/ · master · Matthias Schlögl / gis-blog · GitLab

@suribabu * How to solve this situation

Try this one.

I also met the problem.Can you tell that the way? Thank you !

Just try this code once.
dbekaert/StaMPS: Stanford Method for Persistent Scatterers (

Hi all, Is there any way to automate process of master selection for PSInSAR using SNAP graphs or any other python tool, Can anybody help?

You can select master & automate process.
step 1. SNAP—>Interferometric—>InSAR Stack Overview is very best option to select the master for PSInSAR.

Step2. After the selection of master image using GraphBuilder in Tools, we can automate.

step 3. I think snap2stamps python code also providing the master selection for PSInSAR.

But as per my knowledge we can easily select master and automate process using Step 1 &2 .

@suribabu , it doesn’t looks like we can select master using graphs, as InSAR stack option is not available in graph builder

Yes you are correct. After selection of master only, we can automate the process.
I think @ABraun @thho @gnwiii @marpet will provide better solution for this.

How much Step 8 is important in stamps processing. No proper documentation is provided for that, Can anybody please help, It doesn’t seems like its atmospheric filtering and we are already doing it during PS plotting. Please put some light on it @ABraun sir

Step 8 is described a bit more in this tutorial: StaMPS/ · master · Matthias Schlögl / gis-blog · GitLab

1 Like

Please help , how do you install Matlab 2018a for Linux on Ubuntu WSL.I am using ubuntu16.04 wsl and I tried to install matlab r2018a but I can not, please help

When running the Installer on Linux, I see the below in terminal:

Preparing installation files …

Installing …


the installer does not launch and MATLAB is not installed.
root@DESKTOP-SMROJT0:/mnt/d/R2018a# ls
activate.ini install licenses ui
archives installer_input.txt patents.txt version.txt
bin install_guide.pdf readme.txt
etc java sys
help license_agreement.txt trademarks.txt
root@DESKTOP-SMROJT0:/mnt/d/R2018a# sudo ./install
Preparing installation files …
Installing …
I tried using the suggested solution from mathworks but it didn’t work:
oot@DESKTOP-SMROJT0:/mnt/d/R2018a# ls
activate.ini install licenses ui
archives install_guide.pdf patents.txt version.txt
bin installer_input.txt readme.txt
etc java sys
help license_agreement.txt trademarks.txt
root@DESKTOP-SMROJT0:/mnt/d/R2018a# sudo chmod -R 777 matlab_R2018a_glnxa64
chmod: cannot access ‘matlab_R2018a_glnxa64’: No such file or directory
please help وMy work and results are stalled because of that
thank you in advance

Some large organizations provide Matlab support internally and will know about issues with the organization’s Windows configuration… If that is not your case, you should continue with Mathworks support.

We had some discussions on this here:


Ty so much

I share this post here, in case someone could help me solve the problem in the step 8 of StaMPS