Workflow between SNAP and StaMPS

Thanks your answer, I have followed your instructions but run matlab on Cywin, after run file ps_load_initial_gamma on the matlab it’s error the Figure.


please how did you do to add elevation band to the result

you can check (“add lat/lon band” and “add elevation band” in the interferogram generation in SNAP.

For Alos palsar image what are the steps?
I’ve done the follwoing steps:

  1. Co-register stack with 1 master image and 4 slave,
  2. Interferogram and elevation band.
    But I’m facing the following problem attached in the screen shoot. I’m a new user. Please any one help me.

I’m using windows having 16GB RAM, SNAP 6.0.

In general the steps of preparing Alos PalSAR are mentioned here ALOS PALSAR processing

five images are very few to create PSI, at least you should have 20 images or in some case are mentioned within this forum 12 images are good,

Did you add the elevation and Lat/Lon and subtract the topographic phase in the step of Inteferogram creation?

In your screenshot it is not clear what is in the first and the second raw!


when processing my descending data (20 interferograms, tried mt_prep_snap 0.4 3 2 till 0.4 5 5)
i run into this error at step 1:

READPARM: earth_radius_below_sensor:=6358646.826284111
READPARM: center_range_slc:=867893.7600224181
READPARM: azimuth_lines:=1341
READPARM: prf:=1717.128973878037
Index in position 2 exceeds array bounds.

Error in ps_load_initial_gamma (line 108)

Error in stamps (line 263)

i thought this was due to the patches being to big and therefore the processing requirements to big but i dont think this is the case because my 2016 data( only 9 igs) run in 1 patch.

do any of you have a clue what is wrong here of where i can start solving it? debugging in the ps_load_initial_gamma script?

1 Like

have you also tried to use only one patch? Worked for me in all cases so far.

mt_prep_snap 0.4 1 1 50 200

I don’t know if the last two are required if only one patch is used but I always still added them.

@ABraun as expected this sadly did not solve the problem

Error in ps_load_initial_gamma (line 108)

i think ij is indexed for 3 here in the 2d space but this doesnt exist, any reason how ij can be empty?
or can i open this file and look at it what is going wrong? anybody any idea?

Please get this and let me know. I believe that is will solve your problem.

1 Like

thank you for the share but the new script did not solve the problem, i still have the same error and will just reprocess from snap and see if that fixes it.

maybe something has gone wrong in the export.

thank you!

I am about to start my step 4… PS processing… the “PSI” folder which i obtained from stamps export in windows environment has four folders in it “dem”, “diff0”, “geo” and “rslc”. The following are my queries:

  1. Can i proceed or should i rename any of the folders to proceed?
  2. In which path should i place this PSI folder?

@thho has compiled a step-by-step guide which you can follow along here: Sentinel 1 processing

No need to rename this folder, once it has been created by SNAP,

I think you have double boot windows and Linux, in case you have connected folder between both, remove PSI to the connected folder, because you’ll continue in Linux, once the folder of PSI in Linux,

First thing you should run this command using your shell,

At present i have the “PSI” file obtained as stamps export in my hard disk…
Now, my PSI folder should i rename with INSAR_masterdate and move it in a directory in linux… and then open the terminal in the INSAR_masterdate directory and run mt.prep.snap?

1-move the ‘PSI’ folder to your Linux directory,

2- use the shell to create a new folder, (LINUX)

mkdir ~/INSAR_master_date

3- copy the folder ‘PSI’ into this folder ‘INSAR_master_date’

cp ~/PSI ~/INSAR_master_date

Now you’re ready to start as explained in the previous post.

i couldnt copy the file from hard disk to the linux directory which i created

however without using the code i am able to rightclick copy and paste

Connected folder between WINDOWS AND LINUX, is highly recommended to be in double boot machines, Otherwise, the solution is more complicated to you now, you should copy the folder to the external HD, and then re-boot to LINUX copy and paste the folder there,

i copied the file from my hard disk…
Then i opened the terminal within the copied PSI file which was renamed as INSAR_

I got such…

in matlab:
please guide me to solve these error…