6.0 worked fine, 7.0 doesn't

I’ve upgraded to 7.0 (and degraded back to 6.0) three times during the past six months. I just did it again a few minutes ago and I’m banging my head…

Whenever I try to open a file (any time the SNAP - Open Product window opens) a error message pops up. It says “Not possible to find the goal” and the error message is related to snap64.exe (the error message is in Swedish and I’m translating it quite literally).

When I click OK, it pops up again (it always pops up two times). I can actually go to other directories - one level up or one level down - and then the error message will pop up again. Two times. It’s not actually possible to load any images though.

The same thing happens any time I try to use a tool. Two error messages.

I figure this has something to do with the .home directory. On my company’s network, the home directory has non-Latin characters in it. But this has never been a problem until the release of SNAP 7.0

Any and all help is greatly appreciated. I’ll wait a day or two until I revert back to 6.0.6.


This is caused by invalid shortcuts on your desktop (or in the documents directory of your user folder).

When you open a file, the files in the opened directories are checked (by Java, not SNAP itself) for validity (also the “recent files” of your browser).
You can fix it by removing these invalid shortcuts (shortcuts which refer to a file or folder which is no longer there).

Please have a look here:

Thanks for the reply but, in this case, the problem hasn’t anything to do with shortcuts. I’ve opened the program directly by clicking on snap64.exe in C:\Program Files\snap\bin (both normally and in admin-mode). Same problem.

Now that you mention it, though, I’m almost positive it’s related to Java. I’ll take a stab at that…

It does not make any change how you start SNAP. It is a matter of directories which are selected when SNAP opens a file browser.
I had the same issue after upgrading to version 7, and it can be solved by updating (or deleting) old shortcuts, even if they are not related to SNAP in any way.

To reproduce this error, I created a folder under
and placed a shortcut on my desktop


When I navigate to the desktop with the SNAP file browser, everything is fine:

Now I delete the folder, but leave the shortcut on the desktop. Before the file browser even opens I get this message:

It says: “The element ‘test’ which the shortcut refers to was delted. It can be restored from the trash. Do you want to restore it or delete the shortcut?”

OK. Just to be crystal clear… are you saying that any shortcut I have on the desktop or in various directories can be causing the problem?

How does one “update” shortcuts? I have no shortcuts related to SNAP anywhere on my computer. Are you implying that ALL shortcuts need to be deleted?

Thanks for the help so far!

yes, at the moment. Please have a look at the example above. The folder test was never related to snap in any way - the file browser simply canntot access the full path when I want to open the file browser at the desktop (not even the folder itself).
Just the folders SNAP would open by default (desktop, user profile, user documents, unfortunately also the recent file list) and the folders you actively navigate to are affected.

Basically these locations:

@marpet Can this be solved somehow in any of the next versions??

OK. Thanks for the help. At least I have now a plan :slight_smile:

I’ll reply with a solution if I ever find it.

Could you please shortly confirm that this is the same error message you get?

I think this could be tackled in upcoming versions.

I get a different message but unfortunately (at least for debugging purposes) I’ve uninstalled 7.0 and gone back to 6.0 because I couldn’t find any solution.

The message is a small window that pops up as soon as I attempt to load a file or open a tool.

In the upper left hand corner, it says snap64.exe - sort of like a header.

The body of the message says (I’m going from memory now so I might not be exact): Det går inte att hitta målet

This can basically be translated to “Cannot find the target”, in which the target seems to be the file snap64.exe

I click OK and the message pops up again. Click OK again and it disappears until I do something else. In this way, one can slowly change directories and get SNAP to work but it’s a major headache,