A Bug in SNAP Linux Version for TOPSAR Back-geocoding

Dear all,

I wanted to make an interferogram using one pair of Sentinel-1. I chose the pair using Interferometry Baseline of Alaska Satellite Facility.

I have tried to use SNAP 6 and SNAP 7, upgrading Ubuntu 19.04 to 20.04, changing Java 11 to 8, installing libgforftran4 (as there is no libgfortran3 anymore) but all failed to create the interferogram.
The process stopped when I tried to do registration (TOPSAR Back-Geocoding).

Finally, I decided to use the Windows version and it ran smoothly.



Firman Hadi.
Diponegoro University, Indonesia.

have you tried selecting another DEM (AutoDownload) in the BackGeocoding step?

Maybe the Linux version has problems with accessing the DEM file online.

NASA’s OBPG ran into the problem of missing libgfortran.so.3 with their OCSSW Processing System, so they include the library with the programs. I think it actually comes from CentOS, but works for me on Ubuntu 20.20. If you have access to an 18.04 system you can try installing libgfortran3 and copying (to /usr/lib/x86_64-linux-gnu) onto your system and running ldconfig. If you can’t do that, NASA OBPG git bundle containing libgfortran.so.3 should have the library file.

1 Like