A problem occured during the target product initialisation

I have a problem with the Topographic Phase Removal.
In fact, I can apply the precise orbit, compute co-registration, build the interferogram but I cannot go further.
When I click on the topographic Phase Removal, this window appear :

Here are the parameters that I chose :

I tried with an external DEM, but it is still the same problem.
I tried with sample provided by SNAP and it works. But with my own data, it doesn’t.
Is the problem coming from downloading the SRTM DEM, the lack of space on my hard drive, my data ?

Which version of SNAP are you using? How small is your subset? Do you get the same problem with SRTM 3sec? Is the problem ERS-2 specific? Have you tried on other data? I’ve tried on S1 data using SNAP 5.0 and it worked ok.

I use Sentinel Toolboxes 64bit version 5.0 (with Sentinel Toolboxes only).
The subset is 850*1370 px. But, I tried without subset and it no longer works.
The problem also occured with external DEM and SRTM 3sec DEM.
I tried with Cosmo-SKYMED data and I have the same problem.
Where does the problem can coming from ? Data ?

I have just try with Ensisat Data, and I have no problem.
Do you know if there is some pre-treatement I must do in SNAP software with ERS-2 Data and Cosmo SKYMED data ?

*Envisat data

I also have this problem with S1 data.

3 Likes

I have the problem with S1 data, too. Have you solved it?

Using SNAP v5 and SNAP v6 preview5,

  • I performed Topographic Phase Removal on an S1 interferogram and I did not see the reported error.
  • I performed Topographic Phase Removal on an S1 stack product (not interferogram), I did see the reported error.
    The Topographic Phase Removal operator requires the source product to be an interferogram. Looks like the error could be coming from the source product not being an interferogram.

Hi! I run into the same error when trying to mosaic 4 images. The images are S2, level 1C. They were first resampled to 10 m and then subset to the study area. Then, when using the mosaicing tool, I get the error:

An internal error cocurred during the target product initialisation. 
Type: IllegalArgumentException
Message: Width (0) and height (0) must be >0

Does anyone know what could be the problem in this case?
Thanks in advance!

It would be better if you post your problem in the S2TBX topic.

Done! Thanks, I am new to this forum

I’m trying to run the Enhanced Spectral Diversity on a stack of 13 spitted and orbit-file-applied S1 images. Every time SNAP throws this error as “a problem occurred during the target product processing” Anyone knows how I can manage to solve it?


how do you solve it pls