Acquisition date, track and orbit of S-2 data are not displayed

Hello everyone,

When I add my Sentinel-2 data to Time Series Analysis Settings, the information about acquisition dates, track, and orbit is not displayed, while with Sentinel-1, it is displayed properly. Please see the attached picture for example. I tried with other functions such as Batch Processing, it also displays the same.
So, how can this information of S-2 be displayed in such functions?

Hung Bui

where did you get the S2 products from and has any processing been applied to them in SNAP?

They are original data downloaded from I tried to download them again as well as re-install SNAP but nothing changed.

you are right, the date is not displayed in the table, but I tested with two products and the plot still works.

1 Like

Yes, it is the same to me. I just wonder why the information of S-2 cannot be displayed as S-1 data. It may be a small technical problem of SNAP software, is it right?

maybe because the time-series tool was initially designed for SAR data but as long as you select one common band in the filter menu, you can use it for optical data too.

1 Like

Thank you so much!