Aligning GRD data with GIS data

I have been working with the sentinel-1 GRD data in the SNAP tool for the last month.
My problem is that my output in geotiff format is unaligned with external GIS maps,
when I compare them in QGIS:

I am able to run a small script, so I can compensate for the difference manually in the SNAP created Geotiffs, but I have been looking for at more automatic method to perform the same task.

The best candidates I found was :

But the goal here seems to be DEM based co-registration of multiple GRD data-sets and not alignment with GIS data for an external source. All solutions seem to be using one of the GRD data-sets as the master unit for alignment.
I would instead like to use an external source, but I am not sure what input format would work and what the best procedure forward would be. We also have an external DEM model for the same area:

This DEM model is aligned correctly with all the other GIS information we are using. But I am unsure if it would be better to use this DEM model compared to ones in SNAP. I tried to load the external DEM it into SNAP as a GEOtiff and do co-registration, but the result seems to be an empty map. I might be doing the alignment to early/late in the process,
but I have been unable to find a guide telling me the correct procedure.

I am using SNAP 5.08 on Ubuntu 16.04

The current steps I am using are:

  1. Load GRD scan into SNAP (example:
  2. Radar -> Radiometric -> Calibration
  3. Radar -> Speckle Filtering -> Single Product Speckle Filter (Lee sigma, 7x7, sigma: 0.9, 3x3).
  4. Radar -> Geometric-> Ellipsoide Correction -> Ellipsoid-Correction-GG (BILINEAR_INTERPOLATION)
    Then I attempt to do the co-registration with the external DEM model, but the output seems to be empty.

My main goal is to recreate a paper on determining winterwheat height in agriculture:

But if the RADAR data does not match in global position, I cannot match it correctly to field information as illustrated in the image above.

I have also tried to switch step 4 out with :
Radar -> Terrain Correction -> Range Doppler Terrain Correction and use different internal DEM models,
but the misalignment between GRD and external GIS data still exsist.

What am I doing wrong, or what is the recommended workflow for aligmment with external GIS data using SNAP with Sentinel 1 GRD data ?
Thank you for your help!

You should try Range Doppler Terrain Correction with SRTM 1’’ HGT that you can select directly in SNAP. Results are normally good. Maybe there is something wrong with your external DEMs and/or projections. Your image looks well registered in Google Earth Engine (which uses the s1tbx to produce calibrated geocoded S1 imagery from GRD).

I agree with glemoine: Range Doppler Terrain Correction is much more precise than Ellipsoid Correction.
As you are quite near to the coast, I would recommend unchecking the option to mask out areas without elevation because, depending on the quality of the DEM, this could remove some of the land pixels as well.

1 Like

I tried “Range Doppler Terrain Correction” again, with the settings you recommended:

The problem is that most of the GRD scan seems to be missing from the finished product:
Am unsure what I am doing wrong, since I would expect to get the full area.
I am still following steps 1-3, before doing the “Range Doppler Terrain Correction”
I could remove step 3, but it still does not explain why I am only seeing a small part of the scan.

Maybe the dem wasn’t downloaded correctly. Please try another one from the drop down menu

I solved it, the problem seems to only be pressent in the SNAP GUI tool.
I attempted multiple scans with similar results, but if I restarted the snap tool the result would be correct.
If I instead create a processing graph and usedGPT, the output aligned nicely and I was able to get all my geotiff.
After going through all scans, they seem to align with the GIS data:

Hi. I am having a similar issue. Just to make sure, in the end, did you used Ellipsoid-Correction-GG or Range Doppler Terrain Correction?

Range Doppler Terrain Correction produces the more correct results (depending on the quality of the DEM), but if the image is entirely located over the ocean you don’t have topography and Ellipsoid Correction is sufficient.