Alos 2 Geo-reference


#1

Hi everybody,
I have ALOS 2 data at level 1.5, according to this level, The data should be Geo-referenced. But when data imported using SNAP 2.0.7, aren’t Geo-referenced.
Please guide me.
Thanks and best regards.


Snap error1
#2

Is this CEOS format or GeoTIFF? S1TBX only supports ALOS 2 in CEOS format.


#3

Dear Iveci, This is CEOS format, I overlay the road shapefile with this SAR data but it isn’t georeference.


#4

I have run into similar problems when trying to use ALOS-2 images with level 1.5 processing (also in CEOS format). What I managed to gather from the SNAP source code and the images’ metadata, the geocoding problem seems to stem from the following.

  1. The provided georeferencing metadata does not account for elevation and is quite inaccurate and not too useful. The image should really be reprojected with the Terrain-Correction operator instead, but…
  2. The image, which has been reprojected to ground range, does not have the slant-range-to-ground-range coefficients included in its metadata, making accurate geometric terrain correction currently impossible. SNAP does calculate approximate SRGR coefficients from the near-, mid- and far-range values provided in the metadata but this is not enough.

I resorted to using a trial version of Geomatica to take care of geometric terrain correction, which worked surprisingly well. I guess they use the provided georeferencing metadata to calculate the correct SRGR coefficients before proceeding with terrain correction.

@lveci Is my understanding of the situation correct and are there any plans to improve the geocoding accuracy of ALOS level 1.5 products in SNAP?


#5

Thanks your points were very useful


#6

Hi Valgar
Did you use the trial version of Geomatica 2015? Or the add on Radar Suite for Geomatica?
Cheers!
Terri


#7

Has anyone come up with a solution for this yet? I am using ALOS 2 CEOS Level 1.5 Widebeam data. Also cannot terrain correct using Range-Doppler or SAR Sim. I am getting the error message “Type: Operator Exception, Message: Terrain Correction: Source product should not be map projected”
Any advice would be appreciated, thanks!
Cheers
Terri


#8

The 1.5G is already map projected so you can’t use terrain correction which assumes the data is in SAR geometry.
You should be able to use map reprojection but this won’t correct SAR geometric effects.
Can you get 1.5 detected products which are not map projected? ie 1.5 and not 1.5G
Otherwise, use the 1.1 data.


Change detection and ratio
#9

Hi, thanks for the quick reply. I’m not sure if 1.5 NOT map corrected are an option? Too late to get different products anyways, we’ve already ordered and downloaded our quota for the year. I’ll investigate the Geomatica option for now.
Cheers!


Coordinates disappear when exporting SAR data
#10

Dear all,

I found this topic on the forum, I have quite the same problem than Terri.
I’m currently trying to preprocess ALOS-1 level 1.5 geocoded products and I need to reproject them into WGS 84 UTM as they are projected into GRS-80 according to metadata.
I tried to use the reproject tool but I get an error saying the products should be ellipsoid corrected first.
I then tried to correct (ellipsoid in geolocation grid ) the products but it should not be map corrected.
That is why I don’t have any clue how to go on.
Is there any way to remove map projection from the original product ? Or any other way to preprocess ALOS Palsar products ?

Many thanks in advance,

Kind regards,

Caroline


#11

Dear Caro,
is there a chance of getting the level 1.1 data as well?


#12

Hi All

I just downloaded Snap 4.0 which was released yesterday (8 of July 2016)! Unfortunately the Geo-reference problem still is available for ALOS 2 CEOS Level 1.5 preprocessing and I got following error while I wanted to apply Terrain Correction.

"Source product should not be map projected "

Is there any other solution for solving this problem?

Thanks
Mary


#13

Terrain correction assumes that the source product is in SAR geometry. According to this page ALOS 2 L1.5 is already map projected:

http://www.eorc.jaxa.jp/ALOS-2/en/doc/format.htm


#14

Yes data is map projected! But what we should do for following error while using Terrain Correction option in Snap software?!
"Source product should not be map projected "


#15

If you want to orthorectify the product with a DEM (Terrain Correction), you need to request the same ALOS acquisition in a lower level format, in this case L1.1


#16

gusortiz has stumpled upon a solution for level 1.5 ALOS data.

I cannot promise that it works for any of you but it’s worth a try:



#17

Dear mengdahl,

The L1.5 is projected on Ground Range (GRD) but is not map projected.

Since the SNAP performs the Terrain Correction for Sentinel-1 GRD images, it should comprehend the correction for ALOS GRD images.


#18

The L1.1 (SLC) is not available to all scenes.
Many of them are available only as L1.0 (raw) and L1.5 (GRD).


#19

There are actually two kinds. 1.5 and 1.5G. The 1.5G is map projected and cannot be terrain corrected. It should be possible to reproject it. I’ll have to check if current error checking is to restrictive to allow it.
All detected ALOS products from ASF that I’ve seen are 1.5G.
I see some processed from Australia at level 1.5 which are just GRD but it’s missing SRGR coefficients so can’t be terrain corrected either.


ALOS-1 L1.5 Terrain Correction
#20

ASF has only ALOS products and not ALOS-2? what about the it?