An internal error occurred during the target product initialisation

Hi! I run into this error when trying to mosaic 4 images. The images are S2, level 1C. They were first resampled to 10 m and then subset to the study area. Then, when using the mosaicing tool, I get the error:

An internal error occurred during the target product initialisation.
Type: IllegalArgumentException
Message: Width (0) and height (0) must be >0

Does anyone know why is this error popping up and what can I do to obtain the mosaic I need?
Thanks in advance!

You might have entered invalid parameter values, probably for the mosaicing. Can you show the mosaicing parameters?

Hi TonioF.

Here are my parameters:

Do you see anything out of place?
Thanks in advance!

I think that the error is that you have set the pixel size at 10° (it is in degrees, not in meters). It is a very very high value.

Thank you obarrilero! You were right. Once I changed the Projection to UTM, I was able to set it to 10 m and the mosaic tool worked :smiley:

A post was merged into an existing topic: Mosaic difficulties with Landsat image