Is there any way i can use snappy through anaconda? So when i do import snappy it will not give me an error.

1 Like

these instructions worked for me:

1 Like

I have already used the way you mentioned. You can see snappy folder in python (attached print screen).

But when i open anaconda prompt and then i create a file (.py) having the followning (import snappy) i get the following error ;

Traceback (most recent call last):
File “”, line 1, in
import snappy
ImportError: No module named snappy

I attach the image

When i do the same from IDLE (Python GUI) and not from anaconda i don t have any errors.

Any ideas?

you probably have more than one Python installed (e.g. with QGIS, sen2cor, ArcMap…) . If you enter python.exe in your command shell, the first one stored in the PATH variables is called. If this is a different one than the version where you installed snappy to, it is not found.

Have a look at your PATH environment variable ( and make sure that the directory of your main Python installation (C:\Python27 according to your screenshots) is the uppermost.

1 Like

It worked. One more question why i get this warning:
WARNING: org.esa.snap.core.util.ServiceFinder: Can’t search for SPIs, not a directory: \snap-desktop-plugins
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters

Any ideas?

I get it as well, this is no problem.

Does snappy support 32-bit or 64-bit python?

Java an Python must have the same bitnes.
If you have installed SNAP (including Java VM) in 64 Bit also Python must be 64Bit. The same for 32Bit.
But I would not recommend using 32Bit. 4GB of RAM is not enough to work with remote sensing data. Except you only use old medium/low resolution data.