Any Help : SEN2COR Dll Failed


I have been following the Sen2cor forums for a couple of days trying to get it up and running. I probably did the installation of everything about 4 times over, removing completely, registry values and environment variables then re-installing but for some reason keep receiving the below error. Please any assistance offered would be highly appreciated.

Running Windows 7 Pro 64bit but have installed 32&64 bit versions of Snap, anaconda, etc.

Also after installing Sen2Cor, the images does not open on Snap when displaying the bands?

Hello riyaadh91,
do you have other python library installed apart from the Anaconda python?


I had Python for QGIS but this has been removed, not sure what could be causing this error though. Is there a way to completely removing Anaconda and Python then re-installing from scratch other than the add remove programs feature on Windows 7? I have a feeling something is conflicting.

Latest update, got past the Numpy issue, new problem as per below screenshot, any ideas?

also another update, I loaded the 64bit client back onto the machine and performed the relevant steps. Updated Numpy and Glymur, copied openjp2.dll from sen2cor-2.0.4\sen2cor\build\ and pasted to Anaconda2\scripts as I read on the Forum.


Can someone please share a working version of Sen2Cor as I have tried all versions in the docs as well as online but for some reason keep getting errors after I fix something, the latest error being received is dll failed to load as per below screenshot.

I have ran the sxstrace and below is the output file.
Sen2cor.txt (21.7 KB)

Please any assistance would be highly appreciated.

Managed to sort the DLL issue by installing all versions of Visual C++ Redistribute for VS. receiving the below error now but I read up somewhere that this is caused by the file name being to long or something to that effect.

Good morning Riyaadh,

I also assume that your file path is too long. Windows allows path lengths of 260 characters and it looks like yours is longer. Try to copy your S2A_OPER_…_N02.01 folder into C:\S2\ and it should work.


Hi Abgbaumann,

Thank you for the response, I copied onto the local C:Disk and got a error on 1% complaining about the HDF5.dll that is not loaded correctly, I removed everything including environment variables again rebooted machine then re-installed everything. I again ran the Sen2cor plugin and no errors as yet, seems as if it is stuck on 95% though? any ideas?

It may take a while, depending on your settings. If I would be you I would run it in the Windows command window. There you can actually see what he is doing at the moment. See:


L2A_Process --resolution 10 C:\S2\S2A_OPER_…_N02.01

thank you for the speedy reply, tried the cmd but not sure which path to use, it finished though with the below screenshot, java error, I have seen this in another thread, perhaps I should look in the forum.

also when opening the resulting product, the image looks exactly the same as L1C?

perhaps I am not understanding correctly, but the atmospheric correction is not working, the image still has clouds?

You should use the path to your Sentinel dataset folder. If you stored it in C:/S2/S2A_OPER_… :

…’— S2
…’— S2A_OPER_PRD_MSIL1C_PDMC_…_20151217T103953 <-- Input Path for L2A_Process
…|---- AUX_DATA
…|---- GRANULE
…|---- HTML
…|---- rep_info
…|---- INSPIRE.xml
…|---- S2A_OPER_BWI_MSIL1C_PDMC_…20151217T103953.png


Hi Andreas,

Thank you understood, running the cmd now the file size is already bigger than when I did it via Snap(Sen2cor), awaiting on cmd to complete, will advise on results.

How did you run it on SNAP? Because if you used “–resolution 10” then it will process the data for 10m. If you want them to be processed for 20 or 60 meter you need to use “–resolution 20” or “–resolution 60”

on Snap when I opened the data I selected 20m resolution and on sen2cor I selected 20m as well before clicking run, I am noticing now as the L2A_Process is running, the file gets to about 2gigs then goes back to 700mb then climbs again, without any errors as yet, is the normal for it to respond this way?

it seems like it is compressing after exporting, when the export is nearly finished now, the file is no longer 1GB but 3.5GB then when export completed it is now dropping to 1.8GB instead of 700MB, and also if I look at the files I can see something is occurring, keeping figures X :relaxed:

1 Like

L2A processor works perfectly with the command line, trying to figure out how to remove clouds now and display the NDVI imagery. Thank you very much Andreas for the assistance.

Dear riyaadh91

Can you please helpme regarding installation of Sen2cor?

I got the error as attached: