Apply Orbit File connection problem

Hello. I am not sure if this is a problem our our side. Could you please advise?
I am running SNAP 7.0 on Windows 7 Professional 64-bit

java.net.ConnectException: Connection timed out: connect
OperatorException
Connect to qc.sentinel1.eo.esa.int:443 [qc.sentinel1.eo.esa.int/131.176.235.71] failed: Connection timed out: connect due to Connection timed out: connect

Has it worked before? Could be a temporary issue.

No, I only recently installed V7.0

just for clarification: That means you did not use SNAP before (and therefore cannot tell if it has worked correctly some days ago, or with an earlier version, for example)?

I have used SNAP many times before (V5) but not recently. It may be caused by our firewall, but I do not know. If you want I can send you the full error message.

alright, I understand.
“Timeout” sounds to me that the server-side is not responding. Please go sure if port 443 is open in your firewall settings.

Since when does the problem persist?

Currently, the used location for orbits for S1 is
https://step.esa.int/auxdata/orbits/Sentinel-1/
so my guessing is that some old setting/preference from SNAP 5 (that you previously used) was not deleted.
Try to uninstall SNAP by choosing to delete all previous SNAP data/settings and re-install it.

good point, maybe there are remains of the old snap version.

Am checking. Will get back to you. I do suspect that it is a problem with our firewall.

No. My colleague also has the same problem and he did not have SNAP installed previously.

You’re right.
For S1, I see that the download from QC (using REST API) is tried before the download from STEP auxdata (location indicated previously by me).
I tried a request to QC and it works, so I think the issue is probably on your side: