Apply orbit file tool seems to be broken

Hello all,

I’m new to the forum (and interferometry in general), but I’ve been following some ESA tutorials on how to do some change detection. In the steps where you apply an orbit file, however, I’m running into some problems. I have the following S1A_SLC products:

When I try to apply an orbit file to the February product, I get the no orbit file found error. What caught my attention in this error is that it seems to be looking for an orbit file from 2002:

“No valid orbit file found for 01-FEB-2002 …”
and it says to grab an orbit file from the qc sentinel 1 site and put it into …\POEORB\S1A\2002\02\

Now, I’m guessing it’s seeing 2002 in the filename and running with it, but if this is true, then this tool is very broken!

I’ve tried downloading the correct EOF file from the sentinel 1 qc site (the one the error message tells me to go to) and put it into the folder that it wants, but I still get the same error message.

Furthermore, if I try to apply an orbit to the January image, it successfully downloads and applies it, but when I actually look at the title to the EOF file it downloaded, it’s the complete wrong date range. The file name is: S1A_OPER_AUX_POEORB_OPOD_20200221T120919_V20200131T225942_20200202T005942.EOF

which from what I can tell only applies to products from January 31st to February 2nd. Coincidentally, this file seems to be the one that applies to the February image. go figure.

Any ideas? If this is how the tool always operates, then any S1 products people have been applying orbit files to may be completely wrong and the program/user could potentially have no idea.

1 Like

Hello @palatyle I also encountered this situation. Have you solved it?