Artifacts in GETASSE30 elevation model

There is a strange pattern of artifacts in the results of the topographic phase correction. The DEM used is the GETASSE30 that is automatically downloaded. I checked out the original downloaded DEM and don’t see any artifacts in the original data. Any explanations?

As a side note, it’s still not possible to use an external DEM (my study area is north of 60N) in SNAP 2.0.2

Thanks for any and all help!

would you please to mention the steps you followed, might be we could find the error together

This is caused by the amount of tile overlap needed. GETASSE30 is really low resolution. In the Topo Phase Removal increase the tileExtensionPercent and these should go away. You could also use the ASTER DEM but due to distribution licensing, you will need to get the ASTER DEM tiles yourself and place them in the .snap/auxdata/ASTER 1sec GDEM folder.

1 Like

is this problem of overlap solved in the next SNAP release?

I downloaded the ASTER DEM from NASA but the results are the same as with an external DEM. That is, the slave image is 100% NaN.

The ASTER DEM that I downloaded is a single TIFF with the following name: 20160318073850_2135193536.tif

Does the file need to be split up into specific tiles? If yes, can anyone give me any guidance to do this?

That is not the proper file naming for the ASTER dem. Try here
Just download the tiles in thier original zip format and place them in the “.snap/auxdata/ASTER 1sec GDEM” folder.

There is no problem with the overlap. In this case just set the parameter larger.

Sorry might be I didn’t quite get you, which parameter,

tileExtensionPercent in TopoPhaseRemoval

Thanks a lot Luis! You’ve been a great help.