Atmosheric Correction "file does not exist" Sen2Cor standalone Win10


#1

I’m new to Sen2Corr, so probably things are simpler than I think, but still I would like to know your opinion.

I install Sen2Cor standalone on Win 10 - 64 bit and at the first control it works.

Then I tried to perform atmosheric correction of a S2 image using the command:

L2A_process --GIP_L2A_AC GIP_L2A_AC [path_namefolder].safe

and I got the answer

Sentinel-2 Level 2A Processor (Sen2Cor), 2.4.0, created: 2017.06.05 started ...

file does not exist: C:\Users\lab\Documents\sen2cor\cfg\GIP_L2A_AC

So I decide to copy cfg directory from Sen2Cor installation directory to C:\Users\lab\Documents\sen2cor\cfg (the documents user directory ) and I re-run the process as

L2A_process --GIP_L2A_AC L2A_CAL_AC_GIPP.xml [path_namefolder].safe

and it seems to work: - Sen2Cor runs and produces outputs, but I’m not sure this the right way to address the problem, can someone help me?

Thanks
Renata


#2

I had the same problem, searched for a solution for several days. Thanks to you I solved the problem. I was puzzled by the fact, according to the documentation, that you had to type twice the same thing --GIP_L2A GIP_L2A. Actually, you are correct: you have to type --GIP_L2A L2A_GIBB.xml, which must indicate first the process, and secondly the file to use. So it’s not the copying and pasting of the cfg subfolder which did the trick, but your new syntax.
By the way, if the folder …\documents\cfg is empty, Sen2Cor copies L2A_GIPP.xml into it, but can’t find it if you don’t specify its full name, as you did.
Best,
Patrick