AttributeError: 'bool' object has no attribute 'ARCHIVING_TIME'

Hi there!

I was trying to run the Sen2Cor Atmospheric Correction processor for a Sentinel 2 L1C image but the following message appear: AttributeError: ‘bool’ object has no attribute ‘ARCHIVING_TIME’

I created the path C:\Users\USUARIO\Documents\sen2cor and attend all instructions given by the tutorial.

Hope you can help me

This error was reported a couple of times in this forum but yet with no solution. Maybe we can narrow it down:

Did you already apply any pre-processing to the data?
Where did you download the data?
Can you please give the full name of the image you want to process?

Hi ABraun, thanks for read.
answering your questions:

  1. I didn’t any pre-processing to the data, the first I attempted was try to run the Sen2Cor processor.
  2. I downloaded the data from Copernicus web
  3. The product is called L1C_T18NUL_A015938_20180711T153620

Hope you can help me, thanks again.

please provide the full name so we can check. It is something like this:




I just tried it cannot reproduce the error.

Can you find a difference compared to how you did it?

Hi Andreas,

Wow, you did it!

well, never I’ve seen these code lines beacuse the processor ends when attemtps to read the file.

Let’s search for the reason why it doesn’t work on your side, so sorry if I am asking stupid questions.

Did you somehow rename the folder?This is how it should look like:

Was it extracted successfully? It has 766 MB and contains 103 files with 11 folders.

Are you using the latest version of sen2cor? (02.05.05-win64)
Maybe you have some old versions still floating around which are called when you type L2A_Process
Type in the full path to the bat file and the folder as I did above to go sure.

For example
C:\GIS\sen2cor\L2A_Process.bat D:\S2\S2A_MSIL1C_20180711T153621_N0206_R068_T18NUL_20180711T204317.SAFE
(should be one line only of course)

Hi Andreas,

this is the version of Sen2Cor that I´m using:

And these are the folders that contain the image:

I just do not know if I’ve done something wrong with the files.

If you see something extrange with the information, I’ll be grateful.

Best regards

the only thing that looks strange to me is the *.dim and *.data product inside the original directory. Did you already perform any processing on the S2 data?
Maybe also the ó in the path name is causing trouble or the full path is too long. Copy the *.SAFE folder (without dim and data) to a simple location, such as C:\S2\S2A_MSIL… and run again.

Thanks Andreas,

I’ll do that

I’ve encountered the same error. The first time I ran L2A_Process with a S2 scene an output directory was created for the corrected S2 scene. But I aborted the process before it was finished. When I ran it a second time, I got the error message above. Deleting the output folder solved the problem.