Automatic downloading of precise orbit file fails


#1

Hi,

We’ve also tried to apply precise orbit file to one of the image acquired from early October. And we chose “sentinel precise (auto download)”, however, we got an error saying can not find the file (see attached screen shots below). As a matter of fact, we do find the orbit file via:

https://qc.sentinel1.eo.esa.int/aux_poeorb/S1A_OPER_AUX_POEORB_OPOD_20151023T122449_V20151002T225943_20151004T005943.EOF

And if we put this file under the desired folder, we can precede with the apply orbit file process. So, our question is auto download obit file function really works? Thank you in advance!

Best regards,

Speeder
SkyGeo B.V.


#2

It’s not a fully automated process to store the historic orbits so it
isn’t up to date with the orbits available on the QC website. We’ll be
looking to change this soon.
For now, if you have a product older than a month, it will automatically
find and download the needed precise orbit. If it’s less than a month
since the acquisition and you can find it yourself on the QC website,
then manually put it into the auxdata orbit folder.


#3

I just tested GRDH processing with and without the “Apply Orbit File” step. Surprisingly, the coordinate reference remains exactly the same (up to 15 decimals in WGS84) but I noticed small differences in pixels values, which, while nicely distributed around 1 (no-AOF/with-AOF), show terrain effects.

It should be relatively easy to harvest the orbit files from https://qc.sentinel1.eo.esa.int/aux_poeorb for the most recent dates in some batch process.


#4

@glemoine

I don’t know what this coordinate reference is, but maybe it is not supposed to be changed by the AOF step.
For this particular product, the positional orbit state vectors in the abstracted metadata seem to change by 1-3 meters following AOF, so the AOF TCed image will be slightly shifted wrt the non-AOF TCed image.


#5

Coordinate reference is the combination of the projection (WGS84 lon, lat in this case) and the image coordinates (upper left and pixel spacing). For both files (with/without “Apply Orbit File” step) they are exactly the same:

Origin = (-122.797554574824261,38.071983450993237)
Pixel Size = (0.000089831528412,-0.000089831528412)

If AOF introduces a 1-3 m shift, one would expect a change, if only beyond the 8th decimal in lon, lat or so.
This is apparently not the case. However, pixel values differ slightly (as described), which means that there may have been an effect (only) of AOF on the resampling from SAR geometry to geocorrected values.

Since AOF values are not available for the most recent images, this makes it an awkward step for “within month” systematic stacking of GRDH images, as one would either need to wait one month, reprocess after one month to create a consistent archive, or do without the step altogether and live with small differences.


#6

Could it be that the invalid black pixels around the image (which are not TCed?) make the coordinates of the upper left corner remain unchanged? I.e. the valid pixels are shifted inside a black box of fixed coordinates.

Is it possible in SNAP to co-register a new GRDH image to an ‘old’ AOFed one?


#7

Hi all

I am trying download POD Precise Orbit Ephemerides but this give me a error, somebody have idea that what happen?


#8

If you are trying to download them you shall go here -> https://aux.sentinel1.eo.esa.int/
If you are using Apply orbits operator and it fails its because there were some changes in the server delivering orbits and we are currently updating the orbits catalogue which is used by SNAP. Shall be ok by tomorrow.


#9

It’s all updated! Please try now


#10

Hi, I want download this file, but the download give me a error yet


#11

I wrote you before what is the correct website to download: https://aux.sentinel1.eo.esa.int/
You are still using the old server which is not working indeed.


#12

Oh sorry!!! ok… thanks, I will try again!!!


#13

Hi

The file is not recognised


#15

if you choose in the Apply orbits to download precise S1 orbits it shall work. you dont need to download the orbit file from the server


#16

Please, could do you indicate me which file I have that to download??? so I am making something wrong! :relieved:


#17

Hi,

I not choosed Apply Orbit File, same this give me a error!!! I think that It not recognised the orbit file that I downloaded…

The SNAP continued give me the same error, and in my C files disk I don’t have the 5 (May month) file, It is created automatically for each month with the download of Orbits files with the server past!!!


#18

You don’t have to download anything. The orbit download is done automatically through “Apply Orbit” operator.


#19

Hi,

I am talking about Precise Orbit Ephemerides file (POEORB) :confused: sorry for my insistence, but the SNAP not recognised the file that I downloaded from the link that you indicate me :sob:

The following file no download


#20

If you use SNAP you don’t need to download orbits separately (from the website) SNAP is automatically downloading for you all orbit files. All you need to do is when you use “Apply orbit” operator you need to choose “Precise orbits (Auto download)”
If your processing does not work the cause might be that on the server the orbits are not available yet - however I have checked and orbits for the 5/05/2018 are available.
good luck