Backgeocoding error when using more than one slave

Dear all,

I am encountering a bug with S1-Tops Back-Geocoding in Snap 7.0. I get the following error message when I want to coregister more than one slave simultaneously to the master and have the Output Deramp/Demod Phase Option enabled:

The Product ‘S1B_20161025T224444_20161025T224512_20161025T224509_20161025T224536_Orb_Asm_IW1_Stack’ already contains a band with the name ‘derampDemodPhase_mst_25Oct2016’.

The error disappears when only adding one slave (see below).

Has somebody else faced this problem?
Cheers, Nils

The issue has been tracked by

The problem has been fixed. The fix should be in the next release.


I’m still having issues with this. I am trying to backgeocode five images w/ deramp-demod so that I can apply ESD later on. But when I toggle that option on it throws an error - the same error mention herein.

So the “output deramp” works with two input products, but it doesn’t work with more than two?

that’s correct - if you toggle the option off with >2 it runs but if you try to enable it you get the noted error message.

@jun_lu could you please have a look at this?

We have tried to repeat it the problem on our computer but couldn’t. Could you please provide more details regarding your test, such as the version of SNAP, the product names and the processing steps etc? Thanks

I have 5 SLCs:



After loading the images, I split each of them as I’m only interested in subswath 1 (IW1) and bursts 8-9. I then apply orbit file to precise orbit to each of the split products. Then I go to co-reg the 5 images using S1 TOPS backgeocoding (placing my desired master at the top of the list) - I want the deramp/demod so I can apply ESD later since I have multiple bursts in each SLC image. When I go click the deramp/demod option it complains and gives the noted error ("… **already contains a band with the name ‘derampDemodPhase…").

Then I thought it could an issues related to applying the split before the orbit file step. So I repeated the procedure applying the orbit file step prior to the TOPS split operation - same issue when I go to coreg the images.

Lastly, when you repeat the above steps for a 2 image stack (as opposed to 5 images), things work just fine. The issue with the demod/deramp option toggled on doesn’t throw off the error.

Running v 7.0.3

We have tried your data and procedure with both SNAP v7.0.0 and the latest build on our computer, but still cannot repeat the problem. Could you do an update to your SNAP and build it again to see if you still have the problem? Thanks

Tried after re-install with same issue.

The SNAP installed on my computer was downloaded from and worked fine with your data and procedure. You can use this version (v7.0). If you built SNAP from source code, could you check the source code in from line 335 to line 344 to see if they are the follows?

if (outputDerampDemodPhase) {
final Band mstPhaseBand = new Band(
“derampDemodPhase” + mstSuffix,



If they are not, then you are using the old code before the fix.


I am also still facing this problem. I cannot check the source code at the moment as i cant access my server, but I definitely updated snap to v7 after you said you fixed the issue.

I too downloaded the installer from there - macos.

This is where I downloaded the SNAP v7.0