Bands 1, 8, 9, and 10 missed from sen2cor processing

Hi there,

I installed the most recent version of sen2cor. Just tried one scene. A weird thing is that bands 1, 8, 9, and 10 were not available after sec2cor processing and not listed in the sublist of ‘Bands’. The values for atmospheric corrected reflectance over the ocean are constant. For example, the values for reflectance at band 3 (560 nm) are 0.0005.

Any suggestions or help would be greatly appreciated.


Dear User,

Could you please inform us at which resolution you are running Sen2Cor reporting also the command line used to launch the process.

Thank you,

Hi Fabrizio,

Thanks for your reply.

I run the processing from the interface. I didn’t change any settings.

I tried 10 m and 20 m resolution. I got the same issue that Bands 1, 8,
9, and 10 were not included in the output. The reflectance values over
the ocean are constant.


Dear Jun,

In order to understand if your issue is related to SNAP or to Sen2Cor itself, could you please run the Sen2Cor from Command Window and check if you obtain the same results?

In addition could you please indicate the S2 product name?

Thank you,

Hallo Jun,

indeed running Sen2Cor from command line without specifying any spatial resolution results in processing all spatial resolutions and thus all bands . The bands you are missing are exactly the 60m bands except band 8. I am not sure what settings are used from interface and I have no time for checking at the moment, but I assume you are processing at 20 m spatial resolution. Then bands 2-4 are resampled to 20 m, band 8 is not processed but band 8a and the 60m bands are also not processed. Note, that band 10 will be never provided with the L2A-product because you don’t the surface at this band (except over high mountains).

Your other problem (small constant values for reflectance at band 3) is probably related to overcorrection the atmospheric contribution. Atmospheric correction provides negative reflectances which are replaced by Sen2Cor by a constant, small positive value. Unfortunatley I cannot provide you a workaround for this.


Dear Fabrizio,

I tried to run the processing from the command line. But I got some error. Please see the attached screen shot.

Again, everything ran well from the interface.

Any solution regarding the error shown above?

Regarding the products list, I used the default setting. All bands except bands 1, 8, 9, and 10 were generated. I tried 10 m and 20 m resolution.



Dear dbpg,

Thanks for your reply. Just to be clear, the processed products included band 8b (865 nm) but band 8 (842) was not processed.

Thank you for your explanations regarding the overcorrection of atmospheric contribution. I tried to change the parameters in the L2A_GIPP.xml file. But when I tried load parameters in this file, I got an error saying 'could not load parameters. 'Unknown element ‘Common_Section’. Any workaround on this?


Dear Jun,

The way as you run the Sen2Cor is wrong.
It should be:
L2A_Process --resolution 20

I suggest to save the S2 data directly on the root
= C:\S2A_OPER_PRD_MSIL1C_PDMC_20160222T170148_R020_V20160219T070105_20160219T070105


I have the same problem after running sen2cor. Band 1, 9, 10 were not available.
Any one know why it happens? thankssen2cor

you see here that these are the 60m resolution bands:

Run sen2cor at 60 m resolution as well (same output) and they will be included in the targed product.

1 Like

I am also facing the same problem.
I am not getting to how to process the same output.
Need help !!!
Please provide some screenshots of the codes.