Batch process subset, idepix, c2rcc on OLCI

yes, I’m referring to “Resample” in the c2rccNode and I still get the same error.
It appears as if c2rcc doesn’t support subsetting in the GPT, could it be?

It does, I send you a graph on how I do it, maybe there is something else wrong that I did not detect. The graph is for MCIi and includes idepix, and a final merge, but the steps are more or less the same. [MSI_idepix_mci_merge.xml|attachment]MSI_idepix_mci_merge.xml (2.5 KB)

You can also review your c2rcc parameters, copy them from SNAP and leave the default (to test it).

Which bands do you specify for subsetting? Maybe this is the problem that you don’t keep all the bands?
Also you have the two variables ${region} and ${polygon}. You should only use one. Probably you do it by setting the other to empty string.

hey, @abruescas, I checked your graph and the resample and subset part were identical to mine. Also the c2rcc parameters are OK, as I have already run the graph only with resample and c2rcc nodes, getting good results.

@marpet, I subset all bands. According the variables region and polygon, I leave region to 0,0,0,0 and it subsets according to the polygon.

As I mentioned, the obscure thing is that I have running graphs for subset -> resample and resample -> c2rcc and both deliver the expected results. Only when I merge the three steps subset -> resample -> c2rcc it doesn’t work.

I’ve used you graph and it worked. I only removed the bands the region parameter.
subset-resample-c2rcc_v2.1.xml (2.2 KB)
That’s the command I used:

> gpt "G:\EOData\_temp\subset-resample-c2rcc_v2.1.xml" -t G:\EOData\_temp\c2rcc.dim -Ppolygon="POLYGON((34.61844368266771 31.8634429454803, 34.61723920476815 31.794406725593483, 34.7039466123858 31.769540817450004, 34.72186085597585 31.850216096630355, 34.78487691867303 32.03706823458345, 34.68175630866747 32.07731852323451, 34.68175630866747 32.07731852323451, 34.61844368266771 31.8634429454803))" -PsourceProduct="G:\EOData\SENTINEL2\S2B_MSIL1C_20190506T081609_N0207_R121_T36SXA_20190506T104054.SAFE\MTD_MSIL1C.xml"

Have you installed the latest updates?

I have removed the bands parameter and it works now. Although I have listed all S2 bands there, something was insufficient for compiling.
Many thanks for your feedback!

1 Like

Dear @aewindle. I also try to apply gains for OLCI sensor. I had a look on your graph, look what I need, thank you!
But before I use it I had one questions regarding the step when you apply the System Vicarious Calibration. Can you please explain to me what exactly this expression does?feq(Oa01_radiance, 913.9812317630276, 1.0e-4) ? NaN : Oa01_radiance / ${Oa01_vic}

When I run the graph with gpt I receive the following error: Error: [NodeId: vicarious] Could not parse expression: 'feq(Oa01_radiance, 913.9812317630276, 1.0e-4) ? NaN : Oa01_radiance / {Oa01_vic}'. Undefined symbol '

Thank you very much!
Best, Ionut.

Hi @serban.ioan,

I made a FAQ entry which explains how to apply SVC gains on OLCI data.
Please take a look here:

Dear @marpet,

I am grateful for your answer. It seems to be exactly what I need!

Best whishes,