Batch Processing Problem With 6.0.0 Release


#1

Hi,

Batch Processing tool doesn’t work as intended after release 6.0.0. There were no such problems at release 5.0.0.

1) Open 2 sentinel -1 products.

2) Open Batch Processing Dialog and use “Add Opened” button. As you can see below two products are opened within dialog with the same name.

3) When I click refresh button, it works as intended. But still it does not fix the following problem

**4)**I load Graphs/Radar/Standard Graphs /Calibrate graph and run. Well there are two products and I expect 2 calibrated products. But only one product with name manifest.dim is produced.

It is not the case at 5.0.0. I guess that is a major bug and it ceases work of Batch Processing. It is not related with specific products. I tried it with different products. Not related with just calibration but more generic problem. Since all opened products look with name manifest.safe, all produced target products contain the same name and overwrite each other.


#2

does this checkbox make a difference?


#3

Unfortunately no. It doesn’t change anything, same results


#4

Hi @marpet

Do you have any idea about reported bug above?

Thanks


#5

No, sorry. No idea.

@lveci?


#6

I also came across this problem and found that this helps: Problem of output file name with graph batch process

But you have to stick to this order:

  1. Load all S1 data into the Batch module
  2. Hit refresh to display the names
  3. Uncheck “Keep source product name”
  4. Load your graph file
  5. Hit “Run”

#7

when I make batch processing It gives an error like this:

Does it cause other problems in next steps of my analysis?

What should I do now?


#8

Java heap space indicates that your computer is not strong enough. Large graphs often overload the system’s RAM.



#9

Thank you

How about orbit file error? It shows as 4 MAY 2020 ?

What should I download exactly from the website stated in the link?

the website look like this:


#10

please use the search function of this forum. Many of your questions have been answered already multiple times.

https://forum.step.esa.int/search?q=no%20valid%20orbit%20file%20found

Based on your screenshot, SNAP doesn’t read the correct date from the metadata of the file. Did you already pre-process the data before applying this graph?


#11

Thank you.

I only made subsetting before batch process.


#12

Did you select BEAM DIMAP as an output format? It conserves all the metadata.


#13

Yes I selected it (It is already default).


#14

Did you test if the date was correctly recognized before the subsetting?


#15

In abstracted metadata it is written correctly

and this is the error