Batch Resampling - S2 images used before are now invalid

Hi all,

I’m having an issue with my S2 L2A files with using the Batch Processing tool. I had previously used my S2 files for processing in two different instances, calculating NDVI and NDWI, which were both successful.

Now I am trying to do the same for a third different index but for some reason SNAP now classifies these images as an invalid S2 source product, even though I have used them successfully before. Are there any known issues that can cause this? Would I have to redownload and process my data again?

I am unable to use the gpt in my machine, so I’d have to stick to the SNAP GUI if possible.

EDIT: Just an update on things I’ve tried doing:
· Using batch processing without the S2 Resampling tool makes it get stuck at 2% or 4% (1st or 2nd product). I just changed from band 8 to 8a which has the same resolution as the others, didn’t improve anything.
· Increasing cache
· Deleting cache
· Reinstalling SNAP
· Using SNAP 5.0
· Remade graph files


The problem of calculating indices need some times to resample before hand , because might be a specific index uses different bands resolution,

the second issue please update your SNAP to the latest version SNAP 6. also SNAP 7. Non official version is available ,

More information about using gpt, Please take a look at the following link, an example of resample S2 is already available,

Source :

I’m pretty sure it’s not the time to resample as I have succesfully resampled them before, but for some reason I started getting an error message with the same images “Error: [NodeId: S2Resampling] Invalid S2 Source”. In the event that it did take a long time with this new process, I left the batch running for 24h and it was still stuck at 2%.

And I am currently using SNAP 6.0, I just tried to use 5.0 to see if that would solve the issue. Sorry I didn’t make that clear.

As far as I can tell there’s no solution to this error, I assume the L2A files must have gotten corrupted somehow. So I’m reprocessing all the L1C files and hope this fixes the issue. I’ll update in due course. If anyone can think of any other solutions I would be grateful if I ever run into this issue again, as I’m working with about 500 images and reprocessing everytime will become a pain eventually.

And to clarify, I don’t process all 500 images at once in the Batch Processor. I do them in 50 images per batch, so the processing has never taken longer than 40 minutes.

Wait for 7.0 official, it should be released today.

SNAP 7. beta official is released , might be solve your problem,

Source of the post

Unfortunately, updating to SNAP 7 did not solve the issue. I also downloaded the same data and processed using the same parameters in sen2cor, but SNAP would also classify this data as invalid.

Any other things that I could potentially do to fix this? I can’t think of anything that might be causing the problem, and need a solution relatively soon.

Just replying to say that I managed to run my processing with the GPT after fixing some memory allocation issues. That solved the problem!