Blank result after supervised classification

How did you create the training areas?

Did you try the maxlike classifier as well?

i’m creating the training areas in snap by build a new vector data. I’m trying to classify this morning and still the result didnt show. how do i know that i made a well maxlike classifier?

this the vector that i build

you can see in the frequency is ??? and the description is no data in Colour manipulation

Did you try reprojection as described here: Rndom forest classification steps

i didnt know that i have to. the sentinel data we have to reprojection or the vector of sample data?

reproject the whole raster product. The vectors will be taken in the new product as well.

what type of projection that i have to do in the sentinel 2 data?
so i have to build a new vector? oke i will try then

Simply select Raster > Geometric Operations > Reprojection and choose WGS84 as an output projection. But remote “reproject tie-point grids” as this is a quite unnecessary step and requires lots of time.

Actually, there is no need to build the vectors anew. Make new ones only if the classification fails again after the reprojection.

okey i will try it. hopefully this is work

what is your opinion? is this good training sample for classification? i use a rectangle vector in snap.

anything is suitable as long as it contains clear and representative signatures and the area is large enough.

is there something wrong if im just using a 3 band? ( a natural colour band 2,3, and 4) for classification?

many classifiers rely on the principle that surfaces show different reflectance in the feature space of multi-spectral products which contain many bands. The more bands of distinct information you enter, the more likely are the classes correctly identified by the classifier.

is a resampling the data is needed to make a classification?

the process i did:
radiometric correction sen2cor (but this is not really working good cause thats stoping in 91% process so all the band wasnt processed well) >> resampling >> supervised classification (maximum likehood)

resampling brings all rasters to one common resolution. If you only use RGB that is an unnecessary step because they are all of 10 m.

If you use the full stack, you might need resampling. But have a look at this: Resample processing time

If the sen2cor output wasn’t created correctly I would rather stick to the non-calibrated bands or try to download the L2A product directly (if available).

thank you sir for your advise!! i will try my best haha

and my classification is working when i reprojection to long/lat hahaha finally!

is there any way to check the accuracy for this classification using snap software?

Accuracy assessment is not implemented in SNAP, but you can open your result in QGIS, for example and make it there. Please see here: Classification Validation?

I have the same problem for the MaxVer classification.
I have already done the classification for the Minimum Distance, KNN algorithms for the same training samples and both worked well. Only the MaxVer rating does not work. can anybody help me?
I’ve tried it in several ways … I’ve reproved it.
I am using the Sentinel-2 bands B2, B3, B4, B8 and the NDVI, GNDVI, NDWI and IPVI index. Anyone know about this?



This is the “result”

did you try to reproject the initial data to WGS84 before the classification? This resolved the error in some reported cases: Rndom forest classification steps

Just make sure to uncheck “reproject tie-point grids” to reduce computing time.


Yes, I reproject to WGS84 and I did the classification from this data. I have tried again only with bands B1, B2, B3 and B4 and still with problem, didn’t show up the result. The frequencies appears with “?”

I think it’s strange, because the KNN and Minimal Distance ratings worked with this same data (NDVI,NDWI,GNDVI and B1,B2,B3,B4).
Here are the results:

This is the result for KNN classification for the same data:

I’m having a bit of problem trying to figure out what is going wrong with the classification process made by KNN classifier.
I have two set’s of images for the same place, one from 2015.11.04 taken by S2A at Orbit number 37 that covers 29TNF area and the other from 2018.09.02 taken by S2B at Orbit 37 on the same region.
I’ve a set of trainning areas that I have applied on the image of 2018 (S2B) and used on KNN classifier:

Thus resulting on the following classification:

Then I’ve applied the same vectors to 2015 image (S2A):

But the output its not, somehow, what I was expecting:

I’ve tried with ML and RF classifier with no problem, but with KNN something it’s not right. Can anyone help me understand what could be wrong or what should I try to test?

(I’ve used a land/sea mask)

"No need to reply. Already solved the problem: Bug in vectors:grin: