Bug in PC version implementing RGB band expressions? - not seent on Mac

I have been processing some S2 images on a Mac using a fully updated v. 9.0.0, generating images using the band expressions 12/11, 11/8 and 4/3 for geology enhancements. This works perfectly on Mac OS but migrating to a PC (Win10), again with the latest and updated SNAP, the image using band expressions is bizarre and looks nothing like the Mac version (too red and seems to be sized differently if I compare with other RGB images on split screen. I have tried this now on two Macs and two PCs, same result as shown below:

On the Mac - panels from left RGB = 4_3_2, 12_11_2, 12/11_11/8_4/3

On the PC - panels from left RGB = 12/11_11/8_4/3, 12_11_2, 4_3_2

I am following exactly the same processing steps after resampling to band 2 on both platforms, hence my suspicion of a bug in the Windows version. Puzzling!

I’m a geological engineer. Are these Sentinel 2 band ratios used for lithological classification?

Yes, they seem to show high contrast between e.g. mafic and felsic units.

I have never used Sentinel-2 satellite data for lithology.

I just tried to recreate the RGB on Windows:

The lower right looks similar to what you expect.
I’ve resampled to 20m using the general resampling and then created the three virtual bands and out of them finally the false RGB.