Bug: TC and TF do not work in Graph Builder with external DEM (beta 08)

I am able to use both terrain flattening and terrain correction by calling these operators from the menu system, however I am unable to get them to operate in graph builder mode.

I am using a custom DEM (as I am at a high latitude not covered by SRTM). When I chose the built in DEMs that cover this region, the operation works fine.

But, if using my custom DEM (that works fine outside of graph mode), I get the notice org.esa.snap.core.gpf.graph.GraphException and I am unable to run the operation.

I have tried this in both Mac and Windows using SNAP beta 2.0 08.

apologies if this should have been posted elsewhere.

I’ll also report that the graph works fine running via gpt in the command line.

I also got this exception when tyring to run SAR Simulation Terrain Correction using our own DEM from the menu.

However Range Doppler Terrain Correction runs just fine as a wizard from the menu using our own external DEM. I got a raster what is orthocorrected and resampled to 15 m and has UTM as a reference system. (Besides it creates an output which is shifted by 1-3 pixels compared to optical satellite imagery like SPOT (10m) or pansharpened Landsat 8 (15 m). The optical images are in the same spatial reference system (UTM) and very well registrated intrinsically. I added the geoid undulation to the DEM in order to get Elliposidal Height instead of Elevation. The shift is still present.)

If I try to construct a Graph as follows:

  1. Read
  2. Apply Orbit
  3. Calibration
  4. TOPSAR-Deburst
  5. SAR Simulatin
  6. GCP-Selection
  7. SARSim
  8. Write


  1. Read
  2. Apply Orbit
  3. Calibration
  4. TOPSAR-Deburst
  5. Range Doppler Terrain Correction
  6. Write

I got the same Exception error : org.esa.snap.core.gpf.graph.GraphException

I use SNAP 2.0-beta-08 on Windows 7.

Hello. I’ve got the same error :org.esa.snap.core.gpf.graph.GraphException when I try to use the Range Doppler Terrain Correction on a graph (no problem when I do it from the menu system). I use a custom DEM and I use SNAP beta2.0.08 on Ubuntu 14.0.LTS.
Did you find the solution?

Is there a reason why you apparently use SLC-products even though you don’t appear to use the phase for anything (phase is unusable after Terrain Correction)?

Nope, I was going to try on Debian but after your post I suppose it doesnt matter…
Have you got any shift on the orthocorrected image?

Basically we plan to orthocorrect Polarimetric descriptors which is derived from SLC-product using other software like Polsarpro. I just regard as easier and quicker to calibrate SLC to get a dataset for testing that can be orthocorrected.


I get the same error when using custom DEM with Terrain.Correction tool. Graph builder says ‘org.esa.snap.core.gpf.graph.GraphException’.

@forman ?

Kind regards,