Bursts loss after Back-Geocoding in TOPSAR Coregisteration

Hi All, recently, I use the attached graph to implement TOPSAR interferometric, but I found that some bursts were lost after Back-Geocoding operation.

DSC_InSAR_graph1_sliceAss_IW2_VV_b4_16_bgd_ESD_Ifg_deb.xml (7.4 KB)

ProductSet-Reader Input:
ProductSe-tReader(2) Input:

Apply-Orbit-File Output:

Apply-Orbit-File(2) output:

Back-Geocoding Output:

Is there anyone encountered this problem, what is the reason, and how should I improve it?
I have tried several times, but there still exists this problem, it looks like that some bursts are lost.

It is clear that you used the option
in your graph.

It means that where you have no elevation, SNAP simply remove the area. I see that you use the SRTM dataset. Don’t forget that SRTM is limited in latitude. If you work in Scandinavia, there are places where SRTM should not work. Maybe check this.

Many thanks for your suggestion!
I ignored this setting, following your suggestion, it works normally now.

Good to hear :slight_smile:

Note that this option is checked for a reason. You should probably check for a DEM covering your region

Thanks very much. How should I select a proper DEM? Could you give some suggestion or links?
Thanks in advance!

And now, I just unchecked the “mask out area without elevation”. Is it a good choice? I am not sure about this point.

The DEM helps for the coregistration. However, precise orbits are very accurate and for my applications I noticed that neither Extended Spectral Diversity nor DEM were required to be able to produce good interferograms but I cannot ensure that precise orbits are sufficient all the time though.

Nevertheless, If you want to perform Differential interferometry, you will necessarily need a DEM to remove the topographic phase. Then SNAP enables you to use many other DEM such as GETASSE, ASTER, ACE or your own DEM (GEOTIFF format in WGS84). I let you search the DEM’s metadata yourself, I don’t know them :wink: Some are auto-downloaded and some require that you download the DEM on your own and that you place it into the appropriate folder in your SNAP installation directory. For me it’s /home/qg/.snap/auxdata/dem

Thanks for your great response!

I have not assessed the quality, and it appears there maybe some holes, but you may be interested in this high resolution DSM covering the Artic. Their intention was to cover areas north of 60 that are missing from SRTM.

Many thanks!